apt这样子怎么办?啥都装不成!

为当前最终发行版之前的所有版本提供支持
回复
头像
爱国者黑客
帖子: 608
注册时间: 2006-10-01 14:34
送出感谢: 0
接收感谢: 0

apt这样子怎么办?啥都装不成!

#1

帖子 爱国者黑客 » 2006-11-07 7:11

ls@ubuntu:~$ sudo apt-get install -f
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
有 1 个软件包没有被完全安装或卸载。
需要下载 0B 的软件包。
解压缩后会消耗掉 0B 的额外空间。
正在设置 graphviz-cairo (2.8-2) ...
/var/lib/dpkg/info/graphviz-cairo.postinst: 11: dot: not found
dpkg:处理 graphviz-cairo (--configure)时出错:
子进程·post-installation script·返回了错误号·127
在处理时有错误发生:
graphviz-cairo
E: Sub-process /usr/bin/dpkg returned an error code (1)
ls@ubuntu:~$
头像
爱国者黑客
帖子: 608
注册时间: 2006-10-01 14:34
送出感谢: 0
接收感谢: 0

#2

帖子 爱国者黑客 » 2006-11-07 7:35

E: graphviz-cairo: 子进程·post-removal script·返回了错误号·127
头像
爱国者黑客
帖子: 608
注册时间: 2006-10-01 14:34
送出感谢: 0
接收感谢: 0

#3

帖子 爱国者黑客 » 2006-11-07 7:47

自己解决了!sudo rm -f /var/lib/dpkg/info/graphviz-cairo.postinst
回复

回到 “老旧版本支持”