请教~自己编译新版本软件需要先apt-get remove系统中的旧版本软件吗?

为当前最终发行版之前的所有版本提供支持
回复
头像
Nile
帖子: 990
注册时间: 2006-07-15 11:20
来自: 枫叶刀市
送出感谢: 2 次
接收感谢: 0

请教~自己编译新版本软件需要先apt-get remove系统中的旧版本软件吗?

#1

帖子 Nile » 2010-11-18 14:08

现在想编译bluez4.79代替系统内的4.6,需要先卸载掉系统内的4.6吗?(卸载时还会把一些依赖的包一起卸掉,比较烦人),还是修改configuer ——prefix=/usr/把原先版本覆盖掉?

如果不修改prefix默认安装到local中,应用程序可以根据目录选择,那么守护进程启动的是新版的还是老版的?会不会发生冲突?

请高人指点~谢啦~ :em06
Thinkpad T400
头像
wzssyqa
帖子: 4010
注册时间: 2008-04-07 17:36
来自: 泰安人在阜新
送出感谢: 0
接收感谢: 0

Re: 请教~自己编译新版本软件需要先apt-get remove系统中的旧版本软件吗?

#2

帖子 wzssyqa » 2010-11-18 15:58

这个么,自己打成debian包再装吧,那样会比较省事
头像
hiphen
帖子: 803
注册时间: 2010-08-27 15:53
送出感谢: 0
接收感谢: 1 次

Re: 请教~自己编译新版本软件需要先apt-get remove系统中的旧版本软件吗?

#3

帖子 hiphen » 2010-11-18 16:13

ls, 如何打成debian包的,也说说嘛,俺也不懂~
基础问题,请看入门手册http://people.ubuntu.com/~happyaron/udc-cn/lucid-html/

Acer aspire 4736G / Ubuntu 10.04LTS
Asus eeepc900 / Xandros
Nokia N900 / Maemo 1.2.12
头像
nmsfan
帖子: 18958
注册时间: 2009-10-16 22:46
来自: finland
送出感谢: 16 次
接收感谢: 36 次

Re: 请教~自己编译新版本软件需要先apt-get remove系统中的旧版本软件吗?

#4

帖子 nmsfan » 2010-11-18 16:36

ls这几天没上IRC :em04 :em04
这几天正讲课呢 :em11
>>>>推Ubuntu 桌面培训~~<<<<
>>>>想加入/了解gimp汉化吗,点我吧~<<<<
——————————————————————
不推荐wubi,也不推荐你给别人推荐wubi…………
随心而为的感觉真好……
强推mayhem!!
强推ensiferum
头像
hiphen
帖子: 803
注册时间: 2010-08-27 15:53
送出感谢: 0
接收感谢: 1 次

Re: 请教~自己编译新版本软件需要先apt-get remove系统中的旧版本软件吗?

#5

帖子 hiphen » 2010-11-18 17:44

晕,哪里这么有空啊,要泡妞呵 :em20
基础问题,请看入门手册http://people.ubuntu.com/~happyaron/udc-cn/lucid-html/

Acer aspire 4736G / Ubuntu 10.04LTS
Asus eeepc900 / Xandros
Nokia N900 / Maemo 1.2.12
回复

回到 “老旧版本支持”