装了一个软件出现下面的问题

为当前最终发行版之前的所有版本提供支持
回复
wangwwzj
帖子: 34
注册时间: 2010-11-16 1:41
送出感谢: 0
接收感谢: 0

装了一个软件出现下面的问题

#1

帖子 wangwwzj » 2010-11-20 17:10

我运行如下代码
./configure
出现这个错误:
configure: error: --with-x=yes (default) and X11 headers/libs are not available
然后 :
make
wangww@ubuntu:~/下载/R$ make
make: *** 没有指明目标并且找不到 makefile。 停止。
请问怎么解决啊?
头像
leeaman
帖子: 30702
注册时间: 2007-02-02 18:14
系统: debian sid
送出感谢: 1 次
接收感谢: 23 次

Re: 装了一个软件出现下面的问题

#2

帖子 leeaman » 2010-11-20 17:13

啥软件,可以找deb包还是找deb包吧
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)
头像
adagio
论坛版主
帖子: 22110
注册时间: 2008-02-17 23:47
来自: 美丽富饶的那啥星球
送出感谢: 7 次
接收感谢: 74 次

Re: 装了一个软件出现下面的问题

#3

帖子 adagio » 2010-11-20 17:16

没装编译环境吧?
明天就换大三八!
——8核CPU、8G内存、8T硬盘……
8卡交火,80寸大屏放8个……
IPv8的光纤要8条……

---------------------------------------------------------------------------------
[图片版]新手当自强(续)FAQ
[新手进阶]挂载、fstab、调整linux分区
[图片版]E17桌面环境配置手把手
头像
hiphen
帖子: 803
注册时间: 2010-08-27 15:53
送出感谢: 0
接收感谢: 1 次

Re: 装了一个软件出现下面的问题

#4

帖子 hiphen » 2010-11-21 14:23

1. 编译安装需要自己解决依赖库,很明显你是缺少某库
2. configure没成功你执行make干嘛
3. 参考2楼建议
基础问题,请看入门手册http://people.ubuntu.com/~happyaron/udc-cn/lucid-html/

Acer aspire 4736G / Ubuntu 10.04LTS
Asus eeepc900 / Xandros
Nokia N900 / Maemo 1.2.12
头像
lainme
论坛版主
帖子: 7805
注册时间: 2008-09-13 19:17
系统: Arch Linux (x86_64)
送出感谢: 3 次
接收感谢: 68 次
联系:

Re: 装了一个软件出现下面的问题

#5

帖子 lainme » 2010-11-21 14:59

首先看看源里有没有,然后搜下有没有deb包/PPA。

如果都没有先安装xorg-dev,然后继续执行configure,再提示缺少东西的话一般都装相应的-dev包,实在确定不了可以搜索或者再提问。configure要通过了之后再make
回复

回到 “老旧版本支持”