当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 11 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 怎样宽屏显示
帖子发表于 : 2006-11-07 22:39 

注册: 2005-12-18 13:21
帖子: 92
送出感谢: 0 次
接收感谢: 0 次
我的显卡是nVidia GeForce Go 6150的,宽屏1280*800,可是显示的时候只有1024*768,怎样才能正确显示呢?谢谢。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-11-07 23:33 
头像

注册: 2006-08-17 1:13
帖子: 101
送出感谢: 0 次
接收感谢: 2
编辑/etc/X11/xorg.conf
SubSection "Display"
Depth 24
Modes "1280x800" //设置这一行。
EndSubSection


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-11-08 16:18 

注册: 2006-11-07 17:26
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
不要忘了备份。
sudo cp /etc/x11/xorg.conf /etc/x11/xorg.conf.bak

如果不行了,可以输入以下命令恢复。
sudo cp /etc/x11/xorg.conf.bak /etc/x11/xorg.conf


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-11-08 16:54 

注册: 2005-12-18 13:21
帖子: 92
送出感谢: 0 次
接收感谢: 0 次
按照楼上的方法试了一下,没有成功,不知什么原因.


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-11-08 17:00 
头像

注册: 2006-08-17 1:13
帖子: 101
送出感谢: 0 次
接收感谢: 2
  这样的话就比较麻烦,是驱动的问题了。
  首选建议是升级xorg到7.1,如果你是ubuntu6.10就已经是这个版本,它对宽屏的支持好得多。
  下面的方案是参考方案。

非 Intel 显卡驱动的宽屏笔记本

如果你使用的是非Intel显卡的宽屏笔记本,那么,只需要手工修改 /etc/X11/xorg.conf 中的 Modes 一行为 Virtual 最佳分辨率即可。比如:

Virtual 1024 800


[编辑]
Intel 显卡驱动的宽屏笔记本

如果你使用的是 Intel 显卡( 比如 DELL 的几款宽屏本 ),请执行以下几步操作:

1. 安装 855Resolution。详细内容请查阅 http://perso.wanadoo.fr/apoirier/

本条目尚未完全完成,我们需要您的参与!

2. 运行:

gtf 1280 800 60

即可得到一个 ModeLine。比如:

# 1280x800 @ 60.00 Hz (GTF) hsync: 49.68 kHz; pclk: 83.46 MHz

Modeline "1280x800_60.00" 83.46 1280 1344 1480 1680 800 801 804 828 -HSync +Vsync

3. 把这个 ModeLine 拷贝到 /etc/X11/xorg.conf 中的 Monitor 段。
4. 把 Modes 一行,修改成 Modes “1280x800”
5. 运行:

855resolution -l

得到输出:

855resolution version 0.4, by Alain Poirier

Chipset: 855GM (id=0x35808086)
VBIOS type: 2
VBIOS Version: 3104

Mode 30 : 640x480, 8 bits/pixel
Mode 32 : 800x600, 8 bits/pixel
Mode 34 : 1024x768, 8 bits/pixel
Mode 38 : 1280x1024, 8 bits/pixel
Mode 3a : 1600x1200, 8 bits/pixel
Mode 3c : 1920x1440, 8 bits/pixel
Mode 41 : 640x480, 16 bits/pixel
Mode 43 : 800x600, 16 bits/pixel
Mode 45 : 1024x768, 16 bits/pixel
Mode 49 : 1280x1024, 16 bits/pixel
Mode 4b : 1600x1200, 16 bits/pixel
Mode 4d : 1920x1440, 16 bits/pixel
Mode 50 : 640x480, 32 bits/pixel
Mode 52 : 800x600, 32 bits/pixel
Mode 54 : 1024x768, 32 bits/pixel
Mode 58 : 1280x1024, 32 bits/pixel
Mode 5a : 1600x1200, 32 bits/pixel
Mode 5c : 1920x1440, 32 bits/pixel
Mode 7c : 1280x800, 8 bits/pixel
Mode 7d : 1280x800, 16 bits/pixel
Mode 7e : 1280x800, 32 bits/pixel

其中:Mode 7d 一行,是我们想要的。

6. 运行:

855resolution 7d 1280 800

7. startx,这时候已经 OK 了。

8. 为了以后每次重新启动系统都能自动生效,把 855resolution 7d 1280 800 添加到 /etc/rc.d/rc.local 脚本中。这样每次启动都会自动配置好宽屏了。


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 怎样宽屏显示
帖子发表于 : 2006-11-08 18:27 
头像

注册: 2006-07-06 0:57
帖子: 387
地址: Beijing, PRC
送出感谢: 0 次
接收感谢: 0 次
schur 写道:
我的显卡是nVidia GeForce Go 6150的,宽屏1280*800,可是显示的时候只有1024*768,怎样才能正确显示呢?谢谢。


源里面有个 915resolution。我同事的机器装完就可以正常显示了。


_________________
=================================
Ubuntu 12.04 LTS
Dell Vostro 1450
http://www.lirui.name


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-02-24 12:55 

注册: 2005-12-18 13:21
帖子: 92
送出感谢: 0 次
接收感谢: 0 次
终于顺利解决!方法如下:

nvida显卡驱动的安装

首先,要确认你的系统是全新安装的ubuntu6.10,而不是从6.06升级上来的,否则可能会出问题。
其次,到http://www.nvidia.com/object/unix.html下载对应32/64位版本的驱动,假设放在/home/lans/下面,
删除原有驱动(假设你安装过源里面的nvidia-glx驱动,如果没有装过或曾经手动安装驱动的可以跳过):
sudo apt-get --purge remove nvidia-glx
然后恢复X的设置
sudo cp /etc/X11/xorg.conf.backup /etc/X11/xorg.conf
重启,确定启动正常
然后,执行命令:
sudo gedit /etc/default/linux-restricted-modules-common
在最后的双引号里面添加nv两个字,添加后就是“nv”
预防起动X失败
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.mybackup
如果起动X失败,可以用sudo cp /etc/X11/xorg.conf.mybackup /etc/X11/xorg.conf来灰复X设置,然后起动。

以下为网络上留传的要点,原贴作者多台机器安装没有使用,我安装的时候也没有用,如果不 行,可以尝试(但是会删除受限制模块,导致某些别的硬件无法使用:
sudo apt-get --purge remove nvidia-settings nvidia-kernel-common
sudo rm /etc/init.d/nvidia-*

下面开始安装(对于曾经手动安装nv驱动的,可以在安装的时候选择卸载旧版的驱动):
请拿出一张纸和一支笔,记录下一下的命令,因为我们要去到纯终端里面安装
注销后,按Ctrl+Alt+F1,输入用户名和密码,登录后关闭gdm:
sudo /etc/init.d/gdm stop
然后开始安装(假设下载的文件放在/home/lans/目录下)
sudo sh /home/lans/NVIDIA-Linux-x86-1.0-9629-pkg1.run(如果你下载的是64位驱动 sudo sh /home/lans/NVIDIA-Linux-x86_64-1.0-9629-pkg1.run) (你下载的数字可能不是9629,注意做相应的更改。)
进入安装界面后,首先接受协议,选“接受”
可能会有提示已经安装了旧的驱动(视乎你自己是否有手动安装过),是否删除,选yes就是了,一般会提示缺少模块,问是否网上下载,选“no”, 提示需要自己编译模块,选“ok”,然后编译安装开始,最后提示需要修改xorg.conf,是否允许,选yes,完成安装,选ok。

然后回到终端界面,重启gdm:
sudo /etc/init.d/gdm start
现在可以重启试试驱动是否已经装好,在“应用程序-》系统工具-》NVIDIA X server setting里面可以看到驱动的信息
提示:每次更新内核后都需要重新安装nv的驱动!


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-03-19 19:27 
头像

注册: 2005-12-10 17:36
帖子: 336
地址: 北京市海淀区上地十街辉煌国际
送出感谢: 0 次
接收感谢: 0 次
为什么我按照楼上的方法装完重启,每次都会进不了x?每次都要
schur 写道:
sudo /etc/init.d/gdm stop
schur 写道:
schur 写道:
sudo rmmod nvidia && modprobe nvidia

sudo /etc/init.d/gdm start
才能进X?楼下的弟兄给个解决方案~谢谢


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-04-14 23:43 

注册: 2007-03-18 18:34
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
我也又宽频的问题,希望和大家一起讨论^_^
我的本子是华硕A8H,Intel 945显示芯片。安装6.10之后无法实现1280×800宽屏。
我按照5楼朋友的方法尝试了到了第6步,不同之处在于我用的是915resolution。但是在第七步的时候系统提示无法startx,因为已经运行,提示可以删除/tmp/.X0.lock这个文件。我先备份了一份之后把它删除了,然后执行startx之后,宽屏1280×800能够显示了。但是今天安装的新程序都没有了显示。后来我又重新启动了一下电脑,今天按的软件显示出来了,但是屏幕显示被分割成了左右两块。
之后没法我又把删除的文件恢复了。然后又尝试了其他帖子的方法,试图执行下一步能让配置一直运行。但也没有成功。于是我准备重新按照5楼的方法再实验一下。但是没想到在执行第五步的时候却没法显示出1280×800的选项了……晕啊。
实在没什么办法了,而且第8步/etc/rc.d/rc.local 文件也找到。只有在/etc/rc.local。
刚开始接触linux系统,还是新手哈。请大家指教^_^


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-04-15 9:45 
头像

注册: 2006-10-31 14:49
帖子: 1617
送出感谢: 0 次
接收感谢: 0 次
建议看wiki或安装配置板块的帖子,装好显卡驱动


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-04-15 9:58 
头像

注册: 2007-03-14 14:26
帖子: 575
地址: 我用眼神杀死你
送出感谢: 0 次
接收感谢: 0 次
sudo nvidia-settings


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 11 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译