软件包系统已损坏~求助阿~

为当前最终发行版之前的所有版本提供支持
回复
prince623
帖子: 6
注册时间: 2010-09-28 22:55
送出感谢: 0
接收感谢: 0

软件包系统已损坏~求助阿~

#1

帖子 prince623 » 2010-11-23 18:04

安装sopcast-player后打不开,然后也卸载不了,软件也不能安装和卸载了,也不能更新
显示:
软件包系统已损坏

检查您是否使用了第三方源。如果是就禁用它们,因为它们通常是导致问题的原因。
之后在终端中运行以下命令:apt-get install -f
细节:
sopcast-player

怎么回事儿阿,我是菜鸟,希望有贵人帮帮忙……
头像
astolia
论坛版主
帖子: 3282
注册时间: 2008-09-18 13:11
送出感谢: 1 次
接收感谢: 550 次

Re: 软件包系统已损坏~求助阿~

#2

帖子 astolia » 2010-11-23 18:12

不是说的很清楚了吗?在终端中运行以下命令:apt-get install -f,前面记得加个sudo
prince623
帖子: 6
注册时间: 2010-09-28 22:55
送出感谢: 0
接收感谢: 0

Re: 软件包系统已损坏~求助阿~

#3

帖子 prince623 » 2010-11-23 18:29

astolia 写了:不是说的很清楚了吗?在终端中运行以下命令:apt-get install -f,前面记得加个sudo
执行之后就这样了……

正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
正在更正依赖关系... 完成
将会安装下列额外的软件包:
sp-auth
下列【新】软件包将被安装:
sp-auth
升级了 0 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 41 个软件包未被升级。
有 1 个软件包没有被完全安装或卸载。
需要下载 0B/345kB 的软件包。
解压缩后会消耗掉 893kB 的额外空间。
您希望继续执行吗?[Y/n]y
(正在读取数据库 ... 系统当前共安装有 159806 个文件和目录。)
正在解压缩 sp-auth (从 .../sp-auth_3.2.6~ppa1~maverick2_i386.deb) ...
dpkg:处理 /var/cache/apt/archives/sp-auth_3.2.6~ppa1~maverick2_i386.deb (--unpack)时出错:
正试图覆盖“/usr/bin/sp-sc”,它同时被包含于软件包 gtk-sopcast 0.2.8-1
由于已经达到 MaxReports 限制,没有写入 apport 报告。
dpkg-deb: 子进程 粘贴 被信号(断开的管道) 终止了
在处理时有错误发生:
/var/cache/apt/archives/sp-auth_3.2.6~ppa1~maverick2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

咋办?
头像
astolia
论坛版主
帖子: 3282
注册时间: 2008-09-18 13:11
送出感谢: 1 次
接收感谢: 550 次

Re: 软件包系统已损坏~求助阿~

#4

帖子 astolia » 2010-11-23 18:35

gtk-sopcast和sp-auth两个软件包有冲突。另外不知道你是怎么装的,apt-get方式是不会弄成这样的。
把原来的包都删掉重来过吧
sudo dpkg -r sopcast-player sp-auth gtk-sopcast
prince623
帖子: 6
注册时间: 2010-09-28 22:55
送出感谢: 0
接收感谢: 0

Re: 软件包系统已损坏~求助阿~

#5

帖子 prince623 » 2010-11-23 19:20

astolia 写了:gtk-sopcast和sp-auth两个软件包有冲突。另外不知道你是怎么装的,apt-get方式是不会弄成这样的。
把原来的包都删掉重来过吧
sudo dpkg -r sopcast-player sp-auth gtk-sopcast
谢谢啊~已经好了,我是根据http://www.shamoxia.com/html/y2010/1738.html这上 ... 装了……还是谢谢您阿~感激涕零~
头像
astolia
论坛版主
帖子: 3282
注册时间: 2008-09-18 13:11
送出感谢: 1 次
接收感谢: 550 次

Re: 软件包系统已损坏~求助阿~

#6

帖子 astolia » 2010-11-23 19:31

你以前是不是尝试过通过其他方法安装sopcast?因为我看按你给的那个网址上写的,并不会安装gtk-sopcast。
现在再来sudo apt-get install sp-auth sopcast-player就应该没问题了
prince623
帖子: 6
注册时间: 2010-09-28 22:55
送出感谢: 0
接收感谢: 0

Re: 软件包系统已损坏~求助阿~

#7

帖子 prince623 » 2010-11-23 19:34

astolia 写了:你以前是不是尝试过通过其他方法安装sopcast?因为我看按你给的那个网址上写的,并不会安装gtk-sopcast。
现在再来sudo apt-get install sp-auth sopcast-player就应该没问题了
恩,现在好了,万谢!我们这些菜鸟多希望自己能遇到问题自己解决阿~
回复

回到 “老旧版本支持”