grub问题,stage1/stage2 mismatched (已解决)

为当前最终发行版之前的所有版本提供支持
回复
shepx
帖子: 42
注册时间: 2006-10-31 9:46
送出感谢: 0
接收感谢: 0

grub问题,stage1/stage2 mismatched (已解决)

#1

帖子 shepx » 2006-11-08 12:43

我重装了windows,结果grub启动不了ubuntu了,rescue mode可以进。
启动时显示 Error 6 : Mismatched or corrupt version of stage1/stage2
我运行

grub> find /boot/grub/stage1
grub> root (hd1,1)
grub> setup (hd1)

还是不行,敬请高手指点。

-----------------------------------------------------

已经解决了,删掉了menu.lst里的savedefualt就可以了,也不知道为什么,以前没问题的.
上次由 shepx 在 2006-11-08 21:30,总共编辑 1 次。
shepx
帖子: 42
注册时间: 2006-10-31 9:46
送出感谢: 0
接收感谢: 0

#2

帖子 shepx » 2006-11-08 12:46

错误描述是这样的,请问是什么意思啊?如何解决?
This error is returned if the install command points to incompatible or corrupt
versions of the stage1 or stage2. It can’t detect corruption in general, but this
is a sanity check on the version numbers, which should be correct.
shepx
帖子: 42
注册时间: 2006-10-31 9:46
送出感谢: 0
接收感谢: 0

#3

帖子 shepx » 2006-11-08 14:18

咋的没人回? 这个Error啥意思?
顺便说一下,不知道是不是和硬件有关系
我刚装上了光驱,还重装了windows。
头像
我思故我在
帖子: 101
注册时间: 2006-08-17 1:13
送出感谢: 0
接收感谢: 2 次

#4

帖子 我思故我在 » 2006-11-08 14:54

  错误是说找不到你的引导1与引导2,我的翻译也很烂。
  估计是你的光驱的原因。
  现在你的硬盘可能不再是(hd1),一个办法是进rescue mode查看一下现在的设备情况,再作相应地更改。
shepx
帖子: 42
注册时间: 2006-10-31 9:46
送出感谢: 0
接收感谢: 0

#5

帖子 shepx » 2006-11-08 15:22

谢谢楼上,硬盘我猜应该还是hd1,因为我从rescue mode竟然可以进到gnome,是在grub里进的rescue mode,不选rescue mode 就出现 Error 6
在rescue mode 里
grub-install /dev/hdc2 也不行,不知道怎么办了。
头像
我思故我在
帖子: 101
注册时间: 2006-08-17 1:13
送出感谢: 0
接收感谢: 2 次

#6

帖子 我思故我在 » 2006-11-08 15:29

  那就对照menu.lst里关于rescue mode的启动配置进行修改。
shepx
帖子: 42
注册时间: 2006-10-31 9:46
送出感谢: 0
接收感谢: 0

#7

帖子 shepx » 2006-11-08 16:10

THX ^-^
回复

回到 “老旧版本支持”