这是怎么了???

为当前最终发行版之前的所有版本提供支持
回复
G_will
帖子: 66
注册时间: 2010-06-30 12:43
送出感谢: 0
接收感谢: 0

这是怎么了???

#1

帖子 G_will » 2010-11-25 17:15

我想安装webmin。。。

sudo apt-get install webmin

提示

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
webmin : Depends: libnet-ssleay-perl but it is not going to be installed
Depends: libauthen-pam-perl but it is not going to be installed
Depends: libio-pty-perl but it is not going to be installed
Depends: apt-show-versions but it is not going to be installed
E: Broken packages

怎么了???另外一台机子上也是这么安装的,可以。。。。
G_will
帖子: 66
注册时间: 2010-06-30 12:43
送出感谢: 0
接收感谢: 0

Re: 这是怎么了???

#2

帖子 G_will » 2010-11-25 17:29

这是怎么了?

一样的步骤,怎么一台可以,一台不行。。。。
头像
欣骑士
帖子: 94
注册时间: 2010-01-11 23:51
送出感谢: 0
接收感谢: 0
联系:

Re: 这是怎么了???

#3

帖子 欣骑士 » 2010-11-25 17:41

应该是软件包依赖问题吧。
天下布武!
G_will
帖子: 66
注册时间: 2010-06-30 12:43
送出感谢: 0
接收感谢: 0

Re: 这是怎么了???

#4

帖子 G_will » 2010-11-25 17:46

嗯,怎么修复呢?
头像
tenzu
论坛版主
帖子: 36913
注册时间: 2008-11-21 20:26
送出感谢: 0
接收感谢: 21 次

Re: 这是怎么了???

#5

帖子 tenzu » 2010-11-25 17:58

用相同的源应该可以
头像
欣骑士
帖子: 94
注册时间: 2010-01-11 23:51
送出感谢: 0
接收感谢: 0
联系:

Re: 这是怎么了???

#6

帖子 欣骑士 » 2010-11-25 18:01

有点麻烦。换个源试试呢。在新立得软件管理包中装。
天下布武!
G_will
帖子: 66
注册时间: 2010-06-30 12:43
送出感谢: 0
接收感谢: 0

Re: 这是怎么了???

#7

帖子 G_will » 2010-11-25 18:25

解决了。。

是这样的,安装系统时,会自动更新包,我没有及时取消,所以估计更新了一部分包。

装好后我又换了源,源比较老,所以包就冲突了。


现在换了163的源,更新一遍,可以装了。

不过感觉不是很好,很想重装。。。。。唉。
回复

回到 “老旧版本支持”