装好ubuntu后,xp进不去了,求救阿,我已经身心俱疲了!!

为当前最终发行版之前的所有版本提供支持
回复
xumingjun
帖子: 6
注册时间: 2006-11-08 22:03
送出感谢: 0
接收感谢: 0

装好ubuntu后,xp进不去了,求救阿,我已经身心俱疲了!!

#1

帖子 xumingjun » 2006-11-08 22:10

两次了,都是先装的xp(我的xp是ntfs格式的),然后再装ubuntu,进入开机引导界面,是有windosxp的选项的,但选中之后,闪烁了一下蓝屏就跳回重启了,在论坛上看到有一位朋友和我出了一样的问题,但是按照提供的方法,并没有得到解决,小弟我是菜鸟,希望哪位大侠伸出援助之手阿 !!!
sanebaby
帖子: 227
注册时间: 2006-09-23 6:27
来自: 火星
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 sanebaby » 2006-11-09 1:16

windows系统必须安装于主分区,请先确认XP是否安装在主分区
如果是,可以进ubuntu把你的/boot/grub/menu.lst文件的内容贴出来
还说下你的硬盘分区情况,以及XP安装于那个分区
头像
Lejcey
帖子: 105
注册时间: 2005-08-18 22:24
来自: 广东省中山市
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 Lejcey » 2006-11-09 1:37

实在不行就修复一下XP的引导嘛。
只有当一个人全面了解自己后,他才会知道自己需要的是什么。
同理,只有当一个人全面了解linux以后,他才会知道自己需要的linux软件是什么。
xumingjun
帖子: 6
注册时间: 2006-11-08 22:03
送出感谢: 0
接收感谢: 0

#4

帖子 xumingjun » 2006-11-09 10:06

我用fdisk命令查看了一下,发现只有linux分区下的boot选项才打上了*号,换句话说,是不是意味着引导分区变为了linux的分区,而不是c盘,是不是问题的所在呢,如果是,有什么解决的方法呢?
头像
Lejcey
帖子: 105
注册时间: 2005-08-18 22:24
来自: 广东省中山市
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 Lejcey » 2006-11-09 10:33

用XP的安装盘启动,然后进入故障恢复平台,假设你的windows在c盘,输入fix mbr c:和fix boot c:就行了,然后GRUB就不见了。
只有当一个人全面了解自己后,他才会知道自己需要的是什么。
同理,只有当一个人全面了解linux以后,他才会知道自己需要的linux软件是什么。
xumingjun
帖子: 6
注册时间: 2006-11-08 22:03
送出感谢: 0
接收感谢: 0

#6

帖子 xumingjun » 2006-11-09 10:49

顺便报告一下我的menu.lst文件的关于windows的内容
title Microsoft Windows XP Professional
root(hd0,0)
savedefault
makeactive
chainloader +1
xumingjun
帖子: 6
注册时间: 2006-11-08 22:03
送出感谢: 0
接收感谢: 0

#7

帖子 xumingjun » 2006-11-09 10:57

如果按5楼的仁兄提出的方案,那么如何进入linux呢?
头像
Lejcey
帖子: 105
注册时间: 2005-08-18 22:24
来自: 广东省中山市
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 Lejcey » 2006-11-09 11:06

你试着改一下6楼的root(hd0,0),先启动到LINUX,然后看看Window在那个区,换一下数字试试吧。
hd0,0表示第1块硬盘的第1个区。以此类推,有时候你认为的第一个区,Linux不一定这么认为。仔细查看以后修改这个数字。安装Linux是不会破坏Windows的引导的。
只有当一个人全面了解自己后,他才会知道自己需要的是什么。
同理,只有当一个人全面了解linux以后,他才会知道自己需要的linux软件是什么。
xumingjun
帖子: 6
注册时间: 2006-11-08 22:03
送出感谢: 0
接收感谢: 0

#9

帖子 xumingjun » 2006-11-09 11:10

我的windows是安装在c盘也就是hda1的呀,不会有错的
changys04
帖子: 286
注册时间: 2006-11-08 16:33
送出感谢: 0
接收感谢: 0

#10

帖子 changys04 » 2006-11-09 16:32

支持五楼的,大不了再装个wingrub. :wink:
回复

回到 “老旧版本支持”