新手碰到的rpm包安装的错误,请高手指点

为当前最终发行版之前的所有版本提供支持
回复
soblue
帖子: 417
注册时间: 2006-11-08 6:16
来自: Beijing
送出感谢: 0
接收感谢: 0

新手碰到的rpm包安装的错误,请高手指点

#1

帖子 soblue » 2006-11-10 0:22

我要安装学校给打印机客户端程序,是rpm包格式,我终于将系统的rpm装上以后,满怀希望地运行了如下命令:
rpm -i --scripts novell-iprint-xclient.rpm

结果出来如下提示:
error: 依赖性检测失败:
cups >= 1.1.20 被 novell-iprint-xclient-sh-0.5.20050203-2.i586 所需要
/bin/sh 被 novell-iprint-xclient-sh-0.5.20050203-2.i586 所需要
libatk-1.0.so.0 被 novell-iprint-xclient-sh-0.5.20050203-2.i586 所需要
libc.so.6 被 novell-iprint-xclient-sh-0.5.20050203-2.i586 所需要
libc.so.6(GLIBC_2.0) 被 novell-iprint-xclient-sh-0.5.20050203-2.i586 所 需要
libc.so.6(GLIBC_2.1) 被 novell-iprint-xclient-sh-0.5.20050203-2.i586 所 需要
libc.so.6(GLIBC_2.1.3) 被 novell-iprint-xclient-sh-0.5.20050203-2.i586 所需要
libc.so.6(GLIBC_2.2) 被 novell-iprint-xclient-sh-0.5.20050203-2.i586 所 需要
libc.so.6(GLIBC_2.3) 被 novell-iprint-xclient-sh-0.5.20050203-2.i586 所 需要
libcups.so.2 被 novell-iprint-xclient-sh-0.5.20050203-2.i586 所需要
libdl.so.2 被 novell-iprint-xclient-sh-0.5.20050203-2.i586 所需要
libgdk-x11-2.0.so.0 被 novell-iprint-xclient-sh-0.5.20050203-2.i586 所需要
libgdk_pixbuf-2.0.so.0 被 novell-iprint-xclient-sh-0.5.20050203-2.i586 所需要
libglib-2.0.so.0 被 novell-iprint-xclient-sh-0.5.20050203-2.i586 所需要
libgmodule-2.0.so.0 被 novell-iprint-xclient-sh-0.5.20050203-2.i586 所需要
libgobject-2.0.so.0 被 novell-iprint-xclient-sh-0.5.20050203-2.i586 所需要
libgtk-x11-2.0.so.0 被 novell-iprint-xclient-sh-0.5.20050203-2.i586 所需要
libm.so.6 被 novell-iprint-xclient-sh-0.5.20050203-2.i586 所需要
libpango-1.0.so.0 被 novell-iprint-xclient-sh-0.5.20050203-2.i586 所需要 libpangox-1.0.so.0 被 novell-iprint-xclient-sh-0.5.20050203-2.i586 所需 要
libpangoxft-1.0.so.0 被 novell-iprint-xclient-sh-0.5.20050203-2.i586 所 需要
libz.so.1 被 novell-iprint-xclient-sh-0.5.20050203-2.i586 所需要

最开始我还以为是不是与hiweed不兼容造成的,于是换成xubuntu,结果还是同样地结果。我是个新手,用linux总共还不到2天时间,只要这个打印问题能够解决,我想绝大部分工作可以迁移到linux下了。

哪位高手给指点一下,上面地报告是什么意思,我要怎么做。多谢了。
头像
SuperWar3Fan
帖子: 1263
注册时间: 2006-05-20 6:25
来自: 山东淄博
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 SuperWar3Fan » 2006-11-10 10:38

安装这个软件是干什么?
我看了一下需要安装Cups系统!
sudo apt-get install cupsys
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#3

帖子 BigSnake.NET » 2006-11-10 18:55

放弃rpm吧..用deb
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
头像
我思故我在
帖子: 101
注册时间: 2006-08-17 1:13
送出感谢: 0
接收感谢: 2 次

#4

帖子 我思故我在 » 2006-11-10 18:59

  楼主的问题我在另一区回过了。
  楼上的,我想楼主不是不想用deb,而是没有deb可用,至少我的打印机就只找到了rpm包,连源码包都找不到。
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#5

帖子 BigSnake.NET » 2006-11-10 19:06

那就将缺的东西都安上..

看看源里有没有yum?
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
soblue
帖子: 417
注册时间: 2006-11-08 6:16
来自: Beijing
送出感谢: 0
接收感谢: 0

感谢各位,我还在尝试,更多的东西不明白

#6

帖子 soblue » 2006-11-10 19:58

办公室的打印机是学校IT部门统一管理,用的novell系统(这个是昨天从google上搜索到novell网站才明白novell为支持其suse系统给出的rpm包)。(没有源码)

我昨天用rpm -nodeps(忽略依赖性检验)参数来安装,貌似安装上了,但是再上IT部门的打印管理网页,依然告诉我打印客户端没有安装。这个系统在Windows下的管理过程是这样的:先装打印客户端程序,然后再输入用户名和密码(系统给打印机按用户分配权限,并非随便打印),安装打印驱动程序。

cupsys我刚才装了,再试打印客户端rpm包,还是跟先前一样。

我的Hiweed装上还没几天,还在逐渐熟悉linux的基本东西,现在疑问还多着呢。Hiweed里的firefox版本是1.5,我刚才下载了2.0,是tar.gz2的格式,我就死活不明白这个文件该解压到哪个目录底下合适,因为我看到解压后好像不用安装,直接就可以运行,我现在放的位置是tmp下。

还有,我安装完dia,不知道上哪去运行它,因为菜单里没有,最后我在/usr/bin下发现了它的可执行文件,但我不能每次都开资源管理器,然后找这个目录然后再双击运行呀,于是想在开始菜单里添加了一个dia启动器,发现这个启动器就在离“应用程序”这个开始菜单最近的地方!
回复

回到 “老旧版本支持”