新手碰到的rpm包 安装的错误,请高手指点

为当前最终发行版之前的所有版本提供支持
回复
soblue
帖子: 417
注册时间: 2006-11-08 6:16
来自: Beijing
送出感谢: 0
接收感谢: 0

新手碰到的rpm包 安装的错误,请高手指点

#1

帖子 soblue » 2006-11-10 1:00

我要安装学校给打印机客户端程序,是rpm包格式,我终于将系统的rpm装上以后,满怀希望地运行了如下命令:
rpm -i --scripts novell-iprint-xclient.rpm

结果出来如下提示:
error: 依赖性检测失败:
cups >= 1.1.20 被 novell-iprint-xclient-sh-0.5.20050203-2.i586 所需要
/bin/sh 被 novell-iprint-xclient-sh-0.5.20050203-2.i586 所需要
libatk-1.0.so.0 被 novell-iprint-xclient-sh-0.5.20050203-2.i586 所需要
libc.so.6 被 novell-iprint-xclient-sh-0.5.20050203-2.i586 所需要
libc.so.6(GLIBC_2.0) 被 novell-iprint-xclient-sh-0.5.20050203-2.i586 所 需要
libc.so.6(GLIBC_2.1) 被 novell-iprint-xclient-sh-0.5.20050203-2.i586 所 需要
libc.so.6(GLIBC_2.1.3) 被 novell-iprint-xclient-sh-0.5.20050203-2.i586 所需要
libc.so.6(GLIBC_2.2) 被 novell-iprint-xclient-sh-0.5.20050203-2.i586 所 需要
libc.so.6(GLIBC_2.3) 被 novell-iprint-xclient-sh-0.5.20050203-2.i586 所 需要
libcups.so.2 被 novell-iprint-xclient-sh-0.5.20050203-2.i586 所需要
libdl.so.2 被 novell-iprint-xclient-sh-0.5.20050203-2.i586 所需要
libgdk-x11-2.0.so.0 被 novell-iprint-xclient-sh-0.5.20050203-2.i586 所需要
libgdk_pixbuf-2.0.so.0 被 novell-iprint-xclient-sh-0.5.20050203-2.i586 所需要
libglib-2.0.so.0 被 novell-iprint-xclient-sh-0.5.20050203-2.i586 所需要
libgmodule-2.0.so.0 被 novell-iprint-xclient-sh-0.5.20050203-2.i586 所需要
libgobject-2.0.so.0 被 novell-iprint-xclient-sh-0.5.20050203-2.i586 所需要
libgtk-x11-2.0.so.0 被 novell-iprint-xclient-sh-0.5.20050203-2.i586 所需要
libm.so.6 被 novell-iprint-xclient-sh-0.5.20050203-2.i586 所需要
libpango-1.0.so.0 被 novell-iprint-xclient-sh-0.5.20050203-2.i586 所需要 libpangox-1.0.so.0 被 novell-iprint-xclient-sh-0.5.20050203-2.i586 所需 要
libpangoxft-1.0.so.0 被 novell-iprint-xclient-sh-0.5.20050203-2.i586 所 需要
libz.so.1 被 novell-iprint-xclient-sh-0.5.20050203-2.i586 所需要

最开始我还以为是不是与hiweed不兼容造成的,于是换成xubuntu,结果还是同样地结果。我是个新手,用linux总共还不到2天时间,只要这个打印问题能够解决,我想绝大部分工作可以迁移到linux下了。

哪位高手给指点一下,上面地报告是什么意思,我要怎么做。多谢了。
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#2

帖子 zhuqin_83 » 2006-11-10 1:09

用alien试试。
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
soblue
帖子: 417
注册时间: 2006-11-08 6:16
来自: Beijing
送出感谢: 0
接收感谢: 0

试过了,也不行

#3

帖子 soblue » 2006-11-10 2:29

我用alien转换成deb包,然后再用dpkg安装,报告的错误完全一样。
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#4

帖子 zhuqin_83 » 2006-11-10 3:07

没有deb包么?原码编译呢?
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
头像
我思故我在
帖子: 101
注册时间: 2006-08-17 1:13
送出感谢: 0
接收感谢: 2 次

#5

帖子 我思故我在 » 2006-11-10 18:39

  楼主你的提示是说缺乏以上文件及相关库,把这些依赖性文件安上,再安装rpm才能安装成功。
  
soblue
帖子: 417
注册时间: 2006-11-08 6:16
来自: Beijing
送出感谢: 0
接收感谢: 0

我不知道这些提示是要我装哪些包,我看不懂

#6

帖子 soblue » 2006-11-12 1:34

用“新立得”查来着,没查到。
回复

回到 “老旧版本支持”