[问题] 我刚开始学Linux,装了ubuntu6.10后,发现启动不了windows了,请问这要怎么修复?

为当前最终发行版之前的所有版本提供支持
zhxwin
帖子: 14
注册时间: 2006-11-11 10:16
送出感谢: 0
接收感谢: 0

[问题] 我刚开始学Linux,装了ubuntu6.10后,发现启动不了windows了,请问这要怎么修复?

#1

帖子 zhxwin » 2006-11-11 10:24

错误提示说<windows root>/system32/hal.dll 文件找不到。。。
请各位大大帮忙指点下迷津。在这里先谢谢了。
上次由 zhxwin 在 2006-11-11 21:45,总共编辑 1 次。
shiiuen
帖子: 3
注册时间: 2006-08-11 14:16
送出感谢: 0
接收感谢: 0

#2

帖子 shiiuen » 2006-11-11 10:49

这个简单
打开 /boot/grub/menu.lst

在末尾添加
titile microsoft windows xp
root (hd0,0) ;windows所在盘符
makeactive
chainloader +1
boot
保存,重启
zhxwin
帖子: 14
注册时间: 2006-11-11 10:16
送出感谢: 0
接收感谢: 0

#3

帖子 zhxwin » 2006-11-11 10:52

谢谢楼上的,我马上试试。:)
zhxwin
帖子: 14
注册时间: 2006-11-11 10:16
送出感谢: 0
接收感谢: 0

#4

帖子 zhxwin » 2006-11-11 10:58

那个文档是只读的,我改不了?
头像
again
帖子: 22
注册时间: 2006-11-02 14:37
来自: Nanjing, China
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 again » 2006-11-11 20:27

sudo gedit /boot/grub/menu.list
zhxwin
帖子: 14
注册时间: 2006-11-11 10:16
送出感谢: 0
接收感谢: 0

#6

帖子 zhxwin » 2006-11-11 20:35

谢谢:)
zhxwin
帖子: 14
注册时间: 2006-11-11 10:16
送出感谢: 0
接收感谢: 0

#7

帖子 zhxwin » 2006-11-11 20:47

对了,我原来装了2个Windows操作系统,德文的和中文的,一个在C盘,一个在D盘。我原先进系统也是有选项,让我选择一个Windows进入。请问那个root后面的盘符我应该保持(hd0,0)吗?
zhxwin
帖子: 14
注册时间: 2006-11-11 10:16
送出感谢: 0
接收感谢: 0

#8

帖子 zhxwin » 2006-11-11 21:35

回复楼上的大大,那个命令行我加了,但是错误仍然存在。。。
zhxwin
帖子: 14
注册时间: 2006-11-11 10:16
送出感谢: 0
接收感谢: 0

#9

帖子 zhxwin » 2006-11-11 23:39

再次求救.......还是提示<windows root>/system32/hal.dll文件丢失....
我看了,那个文件在阿........
zhxwin
帖子: 14
注册时间: 2006-11-11 10:16
送出感谢: 0
接收感谢: 0

#10

帖子 zhxwin » 2006-11-12 3:24

问题还是没有解决.....哪位大哥再来救救急,万分感谢阿。
头像
glade
帖子: 1383
注册时间: 2005-10-21 16:57
送出感谢: 0
接收感谢: 0

#11

帖子 glade » 2006-11-12 4:50

一般是由windows的 boot.ini文件不正确所至
头像
SuperWar3Fan
帖子: 1263
注册时间: 2006-05-20 6:25
来自: 山东淄博
送出感谢: 0
接收感谢: 0
联系:

#12

帖子 SuperWar3Fan » 2006-11-12 8:57

应该是硬盘序号改变的问题。
如boot.ini里面是disk(0),你尝试一下其他的选项,如disk(1)/等
zhxwin
帖子: 14
注册时间: 2006-11-11 10:16
送出感谢: 0
接收感谢: 0

#13

帖子 zhxwin » 2006-11-12 9:51

不行阿,boot.ini里面我每个分区都试过了,都不行阿。
fengboli
帖子: 24
注册时间: 2006-11-06 7:55
送出感谢: 0
接收感谢: 0

[建议]

#14

帖子 fengboli » 2006-11-12 9:56

fdisk /mbr
实在不行就恢复。

可以考虑修改grub菜单来恢复,偷懒就重新安装一下grub
#grub
#setup hd0
zhxwin
帖子: 14
注册时间: 2006-11-11 10:16
送出感谢: 0
接收感谢: 0

#15

帖子 zhxwin » 2006-11-12 10:24

楼上的大哥能说的具体点吗?我刚开始学LINUX,都还不懂....先谢谢了。
回复

回到 “老旧版本支持”