troubled by upgrading iBus , Help

为当前最终发行版之前的所有版本提供支持
回复
头像
swordless
帖子: 33
注册时间: 2010-12-13 11:36
送出感谢: 0
接收感谢: 0

troubled by upgrading iBus , Help

#1

帖子 swordless » 2010-12-15 10:45

hey guys, I upgrade my iBus followed the 3steps as :
sudo add-apt-repository ppa:shawn-p-huang/ppa
sudo apt-get update
sudo apt-get install ibus-gtk ibus-qt4 ibus-pinyin ibus-pinyin-db-open-phrase

However, I think I've lost all the input methods, the list menu "select an input method" is blank. Any one might give me some suggestion to fix this problem, Thanks.

It's ubuntu 10.04, upgrade ibus from 1.2 to 1.3.8
附件
Screenshot-4.png
头像
tenzu
论坛版主
帖子: 36913
注册时间: 2008-11-21 20:26
送出感谢: 0
接收感谢: 21 次

Re: troubled by upgrading iBus , Help

#2

帖子 tenzu » 2010-12-15 10:49

have you ever tried reboot your system or reinstall ibus-pinyin?
头像
swordless
帖子: 33
注册时间: 2010-12-13 11:36
送出感谢: 0
接收感谢: 0

Re: troubled by upgrading iBus , Help

#3

帖子 swordless » 2010-12-15 11:00

tenzu 写了:have you ever tried reboot your system or reinstall ibus-pinyin?
absolutely, reinstalled & reboot system, still didn't work
here is the same case like me viewtopic.php?f=8&t=301181
but it seems that the problem are not solved.
Do you think I should uninstall all the ibus packages and then install again?
头像
tenzu
论坛版主
帖子: 36913
注册时间: 2008-11-21 20:26
送出感谢: 0
接收感谢: 21 次

Re: troubled by upgrading iBus , Help

#4

帖子 tenzu » 2010-12-15 11:04

1. remove ibus
2. try to find the config files of ibus and delete them
3. reinstall ibus

another way is to install another input method. fcitx is highly recommended.
头像
swordless
帖子: 33
注册时间: 2010-12-13 11:36
送出感谢: 0
接收感谢: 0

Re: troubled by upgrading iBus , Help

#5

帖子 swordless » 2010-12-15 11:08

tenzu 写了:1. remove ibus
2. try to find the config files of ibus and delete them
3. reinstall ibus

another way is to install another input method. fcitx is highly recommended.
thanks a lot. also do you have any suggestions about the step2 how to find the config files? Searching for the filenames? or whats the keywords?
头像
tenzu
论坛版主
帖子: 36913
注册时间: 2008-11-21 20:26
送出感谢: 0
接收感谢: 21 次

Re: troubled by upgrading iBus , Help

#6

帖子 tenzu » 2010-12-15 11:15

the config files should be in ~/config/ibus or ~/.ibus
头像
swordless
帖子: 33
注册时间: 2010-12-13 11:36
送出感谢: 0
接收感谢: 0

Re: troubled by upgrading iBus , Help

#7

帖子 swordless » 2010-12-15 12:17

tenzu 写了:the config files should be in ~/config/ibus or ~/.ibus
I'm going to install Fcitx. Thank you tenzu!
头像
swordless
帖子: 33
注册时间: 2010-12-13 11:36
送出感谢: 0
接收感谢: 0

God! the same problem againRe: troubled by upgrading iBus ,

#8

帖子 swordless » 2011-01-07 16:57

hey, i am still the guy. i'v installed fcitx & it was working fine for a while. The thing is i cannot input chinese again since today' morning. here is the circumstance:
1.ican switch to chinese input method, but cannot input chinese characters.
2.as you can see, the characters above are different from the characters under english input mode, as this line and the lines following.
3. I'v done sth: ''completely remove'' & remove the file /usr/lib/gtk-2.0/2.10.0/immodules / im-ibus.so & "install" in package manager,both ibus and fcitx. not fixed problem.
i think the point 2 is important, but i have no idea what to do. Can u help me to got it? many thx!
头像
swordless
帖子: 33
注册时间: 2010-12-13 11:36
送出感谢: 0
接收感谢: 0

Re: troubled by upgrading iBus , Help

#9

帖子 swordless » 2011-01-07 22:42

好吧 问题终于解决,首先完全卸载ibus组建,然后在gogle code ibus project. 上面发现一个问题反馈和我的情况非常像,http://code.google.com/p/ibus/issues/de ... %20Summary
http://code.google.com/p/ibus/issues/de ... %20Summary
然后搜索整个目录,找出所有和ibus有关的文件,主要是那些在安装过程中编译产生的文件。最后再重新安装,搞定
回复

回到 “老旧版本支持”