cannot load mysql extension--这个怎么办?请教。

为当前最终发行版之前的所有版本提供支持
回复
shgen
帖子: 30
注册时间: 2010-08-18 14:47
送出感谢: 0
接收感谢: 0

cannot load mysql extension--这个怎么办?请教。

#1

帖子 shgen » 2010-12-17 11:36

phpMyAdmin - Error
Cannot load mysql extension. Please check your PHP configuration. - Documentation
--------------
1.20 I receive the error "cannot load MySQL extension, please check PHP Configuration".

To connect to a MySQL server, PHP needs a set of MySQL functions called "MySQL extension". This extension may be part of the PHP distribution (compiled-in), otherwise it needs to be loaded dynamically. Its name is probably mysql.so or php_mysql.dll. phpMyAdmin tried to load the extension but failed.

==============
这个mysql是以前就装好的。要不行,我把它卸载了再装下。
如果有朋友可以帮忙告诉这样的怎么解决,就不用再重装了。
shgen
帖子: 30
注册时间: 2010-08-18 14:47
送出感谢: 0
接收感谢: 0

Re: cannot load mysql extension--这个怎么办?请教。

#2

帖子 shgen » 2010-12-17 16:18

自己解决了。
就是重新install了下。
$sudo apt-get install libapache2-mod-php5
$sudo apt-get install php5
如果想支持图形就加php5-gd,如果想支持Mysql就加php5-mysql,
回复

回到 “老旧版本支持”