如何配置自己编译的JDK呢?

为当前最终发行版之前的所有版本提供支持
回复
biaoming
帖子: 6
注册时间: 2006-11-04 21:34
送出感谢: 0
接收感谢: 0

如何配置自己编译的JDK呢?

#1

帖子 biaoming » 2006-11-11 21:57

安装好ubuntu后java1.4.2的,现在我从sun网站下载最新的JDK,但在原系统已经的一个了,如何才能替换默认的呢?
xcity
帖子: 135
注册时间: 2006-09-20 17:11
送出感谢: 0
接收感谢: 0

#2

帖子 xcity » 2006-11-12 18:11

解压到随便一个地方。JDK是根据你运行那个地方的java程序来决定用那个JDK环境的,比方说,你运行sun目录下面的java,就是用sun的jdk,你用ubuntu 下面的那个java 1.4.2就是用ubuntu里面的那个。
头像
xiaosilent
帖子: 513
注册时间: 2006-05-09 9:59
来自: 四川成都
送出感谢: 1 次
接收感谢: 0
联系:

#3

帖子 xiaosilent » 2006-11-12 18:31

sudo apt-get install fakeroot java-package java-common
fakeroot make-jpkg jdk-1_5_0_06-linux-i586.bin (替换成实际名字)
在接受许可协议以后,会在当前目录下生成一个.deb文件
sudo dpkg -i *.deb 安装
sudo update-alternatives --config java
配置默认的解释器。
回复

回到 “老旧版本支持”