在ubuntu10.10下如何安装Drcom?

为当前最终发行版之前的所有版本提供支持
回复
rabbet
帖子: 3
注册时间: 2010-12-17 10:52
送出感谢: 0
接收感谢: 0

在ubuntu10.10下如何安装Drcom?

#1

帖子 rabbet » 2010-12-17 21:19

我已经下载了drcom-pum_1.0_all.deb软件,放在当前目录下了。可是在当前目录下执行:
$ sudo apt-get install drcom-pum_1.0_all.deb
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
E: 未发现软件包 drcom-pum_1.0_all.deb
E: 无法按照正则表达式 drcom-pum_1.0_all.deb 找到任何软件包
怎么还找不到drcom-pum_1.0_all.deb呢?
头像
ouc_wentao
帖子: 28
注册时间: 2010-05-30 7:16
送出感谢: 0
接收感谢: 0

Re: 在ubuntu10.10下如何安装Drcom?

#2

帖子 ouc_wentao » 2010-12-17 22:22

你使用的那个命令是用来从 网上的源里安装软件用的 当然找不到软件包了
怎么在终端安装deb包 我也是不很清楚,我也是新手 ,一般我都是直接双击deb包的
rabbet
帖子: 3
注册时间: 2010-12-17 10:52
送出感谢: 0
接收感谢: 0

Re: 在ubuntu10.10下如何安装Drcom?

#3

帖子 rabbet » 2010-12-18 11:02

ouc_wentao 写了:你使用的那个命令是用来从 网上的源里安装软件用的 当然找不到软件包了
怎么在终端安装deb包 我也是不很清楚,我也是新手 ,一般我都是直接双击deb包的
谢谢高手指点.
当我直接双击deb包安装时,在应用程序->互联网->Drcom客户端,启动时,提示
无法找到Drcom认证模块,请在终端运行:
$sudo drcom start
可是在终端运行该命令时提示:
Recompiling drcom kernel module.
* Compile drcom failed. Look at /var/log/drcom-install.log to find out what went wrong.
drcom-install.log 中这样记录:
Compiling drcom kernel module
Wait for a moment...
make -C /lib/modules/2.6.35-22-generic/build M=/tmp/drcom modules
make[1]: 正在进入目录 `/usr/src/linux-headers-2.6.35-22-generic'
CC [M] /tmp/drcom/drcom.o
/tmp/drcom/drcom.c: In function ‘build_ack_skb’:
/tmp/drcom/drcom.c:686: error: ‘struct sk_buff’ has no member named ‘dst’
/tmp/drcom/drcom.c: In function ‘build_auth_skb’:
/tmp/drcom/drcom.c:723: error: ‘struct sk_buff’ has no member named ‘dst’
make[2]: *** [/tmp/drcom/drcom.o] 错误 1
make[1]: *** [_module_/tmp/drcom] 错误 2
make[1]:正在离开目录 `/usr/src/linux-headers-2.6.35-22-generic'
make: *** [default] 错误 2
Compile drcom kernel module failed!
如何解决上述问题?请高手帮帮忙!!谢谢了。 不能上网什么事都做不了....烦.......
头像
ouc_wentao
帖子: 28
注册时间: 2010-05-30 7:16
送出感谢: 0
接收感谢: 0

Re: 在ubuntu10.10下如何安装Drcom?

#4

帖子 ouc_wentao » 2010-12-18 11:59

你是用的什么客户端啊?
我们学校是用的drcom客户端,但是装drcom装不上,换了个别的,用的h3c8021xclient 就能上 校园网了
估计你也是校园网吧?
头像
女祭司
帖子: 19
注册时间: 2009-11-27 15:50
送出感谢: 0
接收感谢: 0

Re: 在ubuntu10.10下如何安装Drcom?

#5

帖子 女祭司 » 2010-12-27 11:35

DRCOM困扰了我们好久。
我现在觉得 编译DRCOM 成功 完全是靠RP的。
回复

回到 “老旧版本支持”