10.10下fstab无法注释?

为当前最终发行版之前的所有版本提供支持
回复
msk1234
帖子: 20
注册时间: 2010-09-14 12:29
送出感谢: 0
接收感谢: 0

10.10下fstab无法注释?

#1

帖子 msk1234 » 2010-12-18 15:54

fstab我是在10.04系统自带的基础上改的,开始是一段带#的注释,在最后我挂上了ntfs分区。
10.04下使用正常,甚至更新到了10.10后也没问题,但是我在10.10下编辑fstab后就出问题了,刚开始提示是

代码: 全选

[mntent]: line 1 in /etc/fstab is bad
把注释行删掉后正常,然后我尝试加入注释行,结果出现

代码: 全选

mount: 挂载点 system><mount 不存在
fstab内容如下

代码: 全选

milo@milo-desktop:~$ cat /etc/fstab
#<file system><mount point><type><options><dump><pass>
proc                                      /proc          proc   nodev,noexec,nosuid     0       0
UUID=cb4a0700-6d84-4221-ad4f-ab2e2641bed1 /              ext4   errors=remount-ro       0       1
UUID=ebd69ad6-c528-4e1a-8b99-002d71d849ea none           swap   sw                      0       0
UUID=E4FCC1A7FCC173F8                     /mnt/diske     ntfs   defaults                0       0
UUID=3EE0637CE0633973                     /mnt/diski     ntfs   defaults                0       0
milo@milo-desktop:~$ sudo mount -a
mount: 挂载点 system><mount 不存在
明显是把注释行当正文处理了。
是注释的问题还是编码的问题?编码我都是用utf-8的,编辑工具是kubuntu自带的kate
头像
hiphen
帖子: 803
注册时间: 2010-08-27 15:53
送出感谢: 0
接收感谢: 1 次

Re: 10.10下fstab无法注释?

#2

帖子 hiphen » 2010-12-18 16:54

加个空格试试?
# <file system> <mount point>
基础问题,请看入门手册http://people.ubuntu.com/~happyaron/udc-cn/lucid-html/

Acer aspire 4736G / Ubuntu 10.04LTS
Asus eeepc900 / Xandros
Nokia N900 / Maemo 1.2.12
msk1234
帖子: 20
注册时间: 2010-09-14 12:29
送出感谢: 0
接收感谢: 0

Re: 10.10下fstab无法注释?

#3

帖子 msk1234 » 2010-12-18 17:20

加上空格就是

代码: 全选

mount: 挂载点   不存在
:em19
头像
hiphen
帖子: 803
注册时间: 2010-08-27 15:53
送出感谢: 0
接收感谢: 1 次

Re: 10.10下fstab无法注释?

#4

帖子 hiphen » 2010-12-18 17:50

这个问题相当有趣,
你确定拿掉注释就没有问题吗?

你是在什么编辑器下编辑的?
你的"#" 号确定是英文符号吗,是不是中文的#
基础问题,请看入门手册http://people.ubuntu.com/~happyaron/udc-cn/lucid-html/

Acer aspire 4736G / Ubuntu 10.04LTS
Asus eeepc900 / Xandros
Nokia N900 / Maemo 1.2.12
Yew Siong
帖子: 1
注册时间: 2011-03-16 20:37
送出感谢: 0
接收感谢: 0

Re: 10.10下fstab无法注释?

#5

帖子 Yew Siong » 2011-03-16 20:41

我也出现类似的问题: mount: mount point 0 does not exist

这是我的fstab记录。

# / was on /dev/sda1 during installation

UUID=bc0855ad-32f5-43c7-9e02-59d7cd33ebf2 / ext4

errors=remount-ro 0 1

# swap was on /dev/sda5 during installation

UUID=92fdb2a3-ef09-46a3-aa91-7242f5b286df none swap sw 0 0

F_drive /home/Host_F vboxsf defaults 0 0

D_drive /home/Host_D vboxsf defaults 0 0

哪位高手帮帮忙~~感激不尽!
头像
自由建客
论坛版主
帖子: 13436
注册时间: 2008-07-30 23:21
系统: Debian stable AMD64
来自: freebuilder@yeah.net
送出感谢: 12 次
接收感谢: 112 次
联系:

Re: 10.10下fstab无法注释?

#6

帖子 自由建客 » 2011-03-17 19:51

FB WARNING
gvim 默认全角井号显示为半角,除非 set ambiwidth=double 。vim 除设置此项外还必须设置相应终端。否则极易混淆。
注释:FB 是 Freebuilder 的缩写,意为自由建客。请勿看成 FBI 。
jtshs256
论坛版主
帖子: 22322
注册时间: 2010-07-19 21:41
系统: OS X
送出感谢: 2 次
接收感谢: 27 次

Re: 10.10下fstab无法注释?

#7

帖子 jtshs256 » 2011-03-17 19:53

怎么都会感觉是framebuffer…… :em06
NO DO NO DIE
http://a/%%30%30
billbear
帖子: 3681
注册时间: 2008-05-03 23:42
送出感谢: 0
接收感谢: 3 次

Re: 10.10下fstab无法注释?

#8

帖子 billbear » 2011-03-18 17:33

5楼多了个回车
回复

回到 “老旧版本支持”