ubuntu10.10安装psp问题

为当前最终发行版之前的所有版本提供支持
回复
oxpuer
帖子: 5
注册时间: 2010-11-13 2:33
送出感谢: 0
接收感谢: 0

ubuntu10.10安装psp问题

#1

帖子 oxpuer » 2010-12-30 20:27

装完系统后,想试下游戏得感觉。于是用google收集了一些关于linux下psp的贴子参考。
在安装时参考论坛得帖子提到依赖libgtk1.2-common和libgtk1.2,用apt-get装不到,新立得显示安装了libgtk2.0.我想有高版本的,这个应该不是问题。
一步一步搞完后双击图标却没有反应。
然后在终端下执行,出现下面的代码:
error while loading shared libraries: libgtkglext-x11-1.0.so.0: cannot open shared object file: No such file or directory
google翻了下,是文件缺失。然后打开新立得查找,没找着libgtkglext-x11-1.0这个软件,倒是有个libgtkglext1是安装好的。
接着去官网上找函数库得套件,我看到眼花了都没找出来那个套件在哪里。
之后在google上疯狂搜刮帖子(翻到国外去了。。)终于找到了最有可能得问题。
amdx64得函数库和i386和函数库不同,无法执行。
我装得是ubuntu10.10-amdx64版本,psx是32进制软体。
求教:1.以上得问题是否成立,如果是这个问题应该如何解决呢。
2.amd64位系统可以装32位系统的共享库吗?如果可以,应该具体怎么操作才能避免出现问题呢?
头像
astolia
论坛版主
帖子: 3190
注册时间: 2008-09-18 13:11
送出感谢: 1 次
接收感谢: 538 次

Re: ubuntu10.10安装psp问题

#2

帖子 astolia » 2010-12-30 21:40

gtk1和gtk2是不兼容的。首先安装ia32-libs。然后用这个自动工具getlibs
http://frozenfox.freehostia.com/cappy/
一般来说,getlibs /path/to/psx它就会自动帮你安装上缺失的32位库文件
如果没有的话,也可以指定安装某个库,语法我忘了,自己装它的deb包后查man吧
oxpuer
帖子: 5
注册时间: 2010-11-13 2:33
送出感谢: 0
接收感谢: 0

Re: ubuntu10.10安装psp问题

#3

帖子 oxpuer » 2010-12-30 22:58

gtk1和gtk2不兼容,那还能装32位库吗,会不会吧原来得删掉。
头像
qlhn
帖子: 736
注册时间: 2006-08-25 10:37
送出感谢: 0
接收感谢: 0
联系:

Re: ubuntu10.10安装psp问题

#4

帖子 qlhn » 2010-12-31 10:51

我也希望linux能玩psp游戏,学习中!
回复

回到 “老旧版本支持”