Leafpad 0.8.17的txt在mp4或则在xp出现乱码

为当前最终发行版之前的所有版本提供支持
回复
yangb
帖子: 28
注册时间: 2010-12-11 17:06
送出感谢: 0
接收感谢: 1 次

Leafpad 0.8.17的txt在mp4或则在xp出现乱码

#1

帖子 yangb » 2010-12-31 20:39

请大家赐教 我在网上根本找不到方法 我装的是 ylmf os 3.0
头像
Sunmover
帖子: 2339
注册时间: 2010-05-24 13:02
来自: 星城长沙
送出感谢: 0
接收感谢: 4 次

Re: Leafpad 0.8.17的txt在mp4或则在xp出现乱码

#2

帖子 Sunmover » 2010-12-31 21:16

换Gedit吧,Ubuntu自带的。。。

代码: 全选

安装Gedit:
sudo aptitude install -y gedit

卸载Leafpad:
sudo apt-get autoremove leafpad

ChinaUnix 写了:好多情况下gedit
在打开windows分区下的文本文件,和下载下来的文本文件时会出乱码的情况,这种情况一般都是由于字符编码的源因,因为linux下缺省情况下是采用
UTF-8的,所以我们最好把GBK,GB2312,之类
的字符编码加上去。步骤是,在终端输入gconf-edit调出gconf-edit(如果没有装,则先安装gconf-edit)
在apps->gedit-
2->preferences->encodings在右边的auto-detected中双击会弹出一个对话框,在那里加入GBK,GB2312,GB18030编码就可以了。
注意,可能还是会不行,这时只要把GBK置顶就可以了
头像
astolia
论坛版主
帖子: 3295
注册时间: 2008-09-18 13:11
送出感谢: 1 次
接收感谢: 553 次

Re: Leafpad 0.8.17的txt在mp4或则在xp出现乱码

#3

帖子 astolia » 2010-12-31 21:35

leafpad保存时,选另存为,下面有个让你选择编码的,你选择其他编码,输入GBK,旁边还有的选换行符的,最好选成CR+LF
yangb
帖子: 28
注册时间: 2010-12-11 17:06
送出感谢: 0
接收感谢: 1 次

Re: Leafpad 0.8.17的txt在mp4或则在xp出现乱码

#4

帖子 yangb » 2011-01-01 9:22

谢谢大家 我试试
yangb
帖子: 28
注册时间: 2010-12-11 17:06
送出感谢: 0
接收感谢: 1 次

Re: Leafpad 0.8.17的txt在mp4或则在xp出现乱码

#5

帖子 yangb » 2011-01-01 9:28

用3楼的方法还是会在mp4中出现乱码哦 试试 gedit
我以前用过它 只不过ylmf os 3.0 没有安装它
回复

回到 “老旧版本支持”