apt-get install 出错

为当前最终发行版之前的所有版本提供支持
回复
zhfg45
帖子: 13
注册时间: 2006-11-13 21:07
送出感谢: 0
接收感谢: 0

apt-get install 出错

#1

帖子 zhfg45 » 2006-11-13 21:31

大家好.我是新来的.第一次在这里发帖请教.有什么不对的地方还请原谅.是这样的:

我安装的是ubuntu 6.06 开机就能进入图型界面的那种。 我在终端里使用"apt-get install"来安装软件的时候系统出现以下提示:

正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
正在更正依赖关系... 失败。
下列的软件包有不能满足的依赖关系:
language-support-en: 依赖: mozilla-firefox-locale-en-gb 但是它还没有被安装
依赖: myspell-en-gb 但是它还没有被安装
依赖: myspell-en-us 但是它还没有被安装
依赖: aspell-en 但是它还没有被安装
依赖: wamerican 但是它还没有被安装
依赖: wbritish 但是它还没有被安装
E: 错误,pkgProblemResolver::Resolve 发生故障,这可能是有软件包被要求保持现状的缘故。
E: 无法更正依赖关系


我弄了半天也没有弄好。无从下手啊。请问这个问题怎么解决呢。困惑我好几天了。
头像
goldfox_79
帖子: 1937
注册时间: 2005-10-16 8:26
来自: 地球
送出感谢: 0
接收感谢: 1 次
联系:

#2

帖子 goldfox_79 » 2006-11-13 21:41

你用的源是dapper的吗
zhfg45
帖子: 13
注册时间: 2006-11-13 21:07
送出感谢: 0
接收感谢: 0

#3

帖子 zhfg45 » 2006-11-13 21:51

我的 sources.list 文件内容不得是这样的:
deb http://ubuntu.cn99.com/ubuntu/ edgy main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ edgy-security main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ edgy-updates main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ edgy-proposed main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ edgy-backports main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ edgy main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ edgy-security main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ edgy-updates main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ edgy-proposed main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ edgy-backports main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu-cn/ edgy main restricted universe multiverse

我也不知道对不对!请帮忙看看
if
帖子: 62
注册时间: 2006-09-12 1:25
送出感谢: 0
接收感谢: 0

#4

帖子 if » 2006-11-13 22:00

头像
goldfox_79
帖子: 1937
注册时间: 2005-10-16 8:26
来自: 地球
送出感谢: 0
接收感谢: 1 次
联系:

#5

帖子 goldfox_79 » 2006-11-13 22:04

zhfg45 写了:我的 sources.list 文件内容不得是这样的:
deb http://ubuntu.cn99.com/ubuntu/ edgy main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ edgy-security main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ edgy-updates main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ edgy-proposed main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ edgy-backports main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ edgy main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ edgy-security main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ edgy-updates main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ edgy-proposed main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ edgy-backports main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu-cn/ edgy main restricted universe multiverse

我也不知道对不对!请帮忙看看
你的系统是6.06 dapper,但是源却是6.10 edgy的,所以装不上,把sources.list中所有的"edgy"替换成"dapper"再装
zhfg45
帖子: 13
注册时间: 2006-11-13 21:07
送出感谢: 0
接收感谢: 0

#6

帖子 zhfg45 » 2006-11-13 22:42

谢谢楼上的几位大哥。呵呵,我已经删除了那个损坏的包。


我都不太会看版本的。
zhfg45
帖子: 13
注册时间: 2006-11-13 21:07
送出感谢: 0
接收感谢: 0

#7

帖子 zhfg45 » 2006-11-13 22:43

谢谢楼上的几位大哥。呵呵,我已经删除了那个损坏的包。


我都不太会看版本的。
回复

回到 “老旧版本支持”