apt-get install 出错

为当前最终发行版之前的所有版本提供支持
回复
zhfg45
帖子: 13
注册时间: 2006-11-13 21:07
送出感谢: 0
接收感谢: 0

apt-get install 出错

#1

帖子 zhfg45 » 2006-11-13 21:32

大家好.我是新来的.第一次在这里发帖请教.有什么不对的地方还请原谅.是这样的:

我安装的是ubuntu 6.06 开机就能进入图型界面的那种。 我在终端里使用"apt-get install"来安装软件的时候系统出现以下提示:

正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
正在更正依赖关系... 失败。
下列的软件包有不能满足的依赖关系:
language-support-en: 依赖: mozilla-firefox-locale-en-gb 但是它还没有被安装
依赖: myspell-en-gb 但是它还没有被安装
依赖: myspell-en-us 但是它还没有被安装
依赖: aspell-en 但是它还没有被安装
依赖: wamerican 但是它还没有被安装
依赖: wbritish 但是它还没有被安装
E: 错误,pkgProblemResolver::Resolve 发生故障,这可能是有软件包被要求保持现状的缘故。
E: 无法更正依赖关系


我弄了半天也没有弄好。无从下手啊。请问这个问题怎么解决呢。困惑我好几天了。
wentalker
帖子: 9
注册时间: 2006-11-13 18:25
送出感谢: 0
接收感谢: 0

ur command incompleted

#2

帖子 wentalker » 2006-11-13 23:25

probably ur command is incompleted

you could try it out bying "sudo apt-get install"

maybe it works i am a newbie also
wentalker
帖子: 9
注册时间: 2006-11-13 18:25
送出感谢: 0
接收感谢: 0

ur command incompleted

#3

帖子 wentalker » 2006-11-13 23:26

probably ur command is incompleted

you could try it out bying "sudo apt-get install"

maybe it works i am a newbie also
wentalker
帖子: 9
注册时间: 2006-11-13 18:25
送出感谢: 0
接收感谢: 0

ur command incompleted

#4

帖子 wentalker » 2006-11-13 23:27

probably ur command is incompleted

you could try it out by using "sudo apt-get install"

maybe it works i am a newbie also
头像
Ray
帖子: 387
注册时间: 2006-07-06 0:57
来自: Beijing, PRC
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 Ray » 2006-11-14 17:58

启动到recover模式 然后看看这样行不行: sudo apt-get -f install
=================================
Ubuntu 12.04 LTS
Dell Vostro 1450
http://www.lirui.name
0406410525
帖子: 42
注册时间: 2006-08-15 20:16
送出感谢: 0
接收感谢: 0

#6

帖子 0406410525 » 2006-11-15 14:15

我的也这样
不行

新立得也用不了,显示下面的

软件索引已被破坏

无法安装或删除任何软件。请使用包管理软件"synaptic"或在终端运行"sudo apt-get install -f"来修正这个问题。


但是进了终端也不好用,不能自动更新啦,哎!!!!
我是按照DRI上安装855的显卡驱动才这样的,无奈啦
头像
SuperWar3Fan
帖子: 1263
注册时间: 2006-05-20 6:25
来自: 山东淄博
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 SuperWar3Fan » 2006-11-16 9:20

sudo aptitude install 软件名称
chenzhouc
帖子: 131
注册时间: 2006-08-28 16:52
来自: 上海外国语大学
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 chenzhouc » 2006-11-18 14:39

apt-get install -f
apt-get upgrade -f
apt-get dist-upgrade
或者更新源
Sunken Boot
头像
xiaosilent
帖子: 513
注册时间: 2006-05-09 9:59
来自: 四川成都
送出感谢: 1 次
接收感谢: 0
联系:

#9

帖子 xiaosilent » 2006-11-18 15:37

没有遇见过这样的情况, 可以考虑换个源试试看。
回复

回到 “老旧版本支持”