安装tar.gz包出问题。请教!(已解决)

为当前最终发行版之前的所有版本提供支持
回复
头像
funiculy
帖子: 140
注册时间: 2010-10-13 7:44
送出感谢: 0
接收感谢: 0

安装tar.gz包出问题。请教!(已解决)

#1

帖子 funiculy » 2011-01-04 15:39

我想要更新Gnome do 到0.8.4,可是PPA源呢一直都是什么无法检索到。于是就下载了tar.gz包。
我解压后是这样的
screenshot2.png
然后
screenshot3.png
screenshot3.png (6.71 KiB) 查看 559 次
于是显示就是
screenshot4.png
这个时候我再怎么make make install都是没有用的。
是怎么回事?
上次由 funiculy 在 2011-01-04 23:32,总共编辑 1 次。
头像
懒蜗牛Gentoo
论坛版主
帖子: 7284
注册时间: 2007-03-02 17:36
送出感谢: 0
接收感谢: 95 次

Re: 安装tar.gz包出问题。请教!

#2

帖子 懒蜗牛Gentoo » 2011-01-04 16:11

把它说没有的那些包都装上
虽然世上没有完美的东西,但这并不影响我们追求完美,因为只有偏执狂才TMD能成功。
10.04新手入门——笨兔兔讲述自己的故事
头像
tenzu
论坛版主
帖子: 36913
注册时间: 2008-11-21 20:26
送出感谢: 0
接收感谢: 21 次

Re: 安装tar.gz包出问题。请教!

#3

帖子 tenzu » 2011-01-04 16:22

直接运行install.sh就行了吧
缺的包还是得装
头像
funiculy
帖子: 140
注册时间: 2010-10-13 7:44
送出感谢: 0
接收感谢: 0

Re: 安装tar.gz包出问题。请教!

#4

帖子 funiculy » 2011-01-04 18:15

貌似这几个包新立得里面都没有噢,网络上也只找到 Glb 和 Gtk 的。
头像
zerroking
帖子: 104
注册时间: 2006-05-12 18:03
来自: 湖北
送出感谢: 3 次
接收感谢: 0

Re: 安装tar.gz包出问题。请教!

#5

帖子 zerroking » 2011-01-04 19:05

看样子你根本没有安装基本的编译环境,新立得里搜一下glib-devel、gtk+-devel等等之类的东西,总之提示什么NO XXXX found,就去安装XXXX-dev或xxxx-devel。

编译就是一件折磨人的事,我不得不说,编译就是开发者偷懒把工作推给用户的行为。 :em06
头像
funiculy
帖子: 140
注册时间: 2010-10-13 7:44
送出感谢: 0
接收感谢: 0

Re: 安装tar.gz包出问题。请教!

#6

帖子 funiculy » 2011-01-04 19:49

zerroking 写了:看样子你根本没有安装基本的编译环境,新立得里搜一下glib-devel、gtk+-devel等等之类的东西,总之提示什么NO XXXX found,就去安装XXXX-dev或xxxx-devel。

编译就是一件折磨人的事,我不得不说,编译就是开发者偷懒把工作推给用户的行为。 :em06
我按照这个
git clone git://git.gnome.org/gtk+
git clone git://git.gnome.org/glib
后,发现还是没有用阿。
这个是不是只是下载下来了gtk glib,然后还要安装呢?
请问是下载到什么地方去了?
头像
leeaman
帖子: 30702
注册时间: 2007-02-02 18:14
系统: debian sid
送出感谢: 1 次
接收感谢: 23 次

Re: 安装tar.gz包出问题。请教!

#7

帖子 leeaman » 2011-01-04 19:51

等ppa更新是好办法~~~
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)
头像
funiculy
帖子: 140
注册时间: 2010-10-13 7:44
送出感谢: 0
接收感谢: 0

Re: 安装tar.gz包出问题。请教!

#8

帖子 funiculy » 2011-01-04 20:03

只是PPA的源一直显示的是:“无效的索引文件,有一些索引文件不能下载,它们可能被忽略了,也可能转而使用了旧的索引文件。”
头像
zerroking
帖子: 104
注册时间: 2006-05-12 18:03
来自: 湖北
送出感谢: 3 次
接收感谢: 0

Re: 安装tar.gz包出问题。请教!

#9

帖子 zerroking » 2011-01-04 20:17

funiculy 写了:
zerroking 写了:看样子你根本没有安装基本的编译环境,新立得里搜一下glib-devel、gtk+-devel等等之类的东西,总之提示什么NO XXXX found,就去安装XXXX-dev或xxxx-devel。

编译就是一件折磨人的事,我不得不说,编译就是开发者偷懒把工作推给用户的行为。 :em06
我按照这个
git clone git://git.gnome.org/gtk+
git clone git://git.gnome.org/glib
后,发现还是没有用阿。
这个是不是只是下载下来了gtk glib,然后还要安装呢?
请问是下载到什么地方去了?
不能apt-get install 么?
头像
funiculy
帖子: 140
注册时间: 2010-10-13 7:44
送出感谢: 0
接收感谢: 0

Re: 安装tar.gz包出问题。请教!

#10

帖子 funiculy » 2011-01-04 20:21

zerroking 写了:
funiculy 写了:
zerroking 写了:看样子你根本没有安装基本的编译环境,新立得里搜一下glib-devel、gtk+-devel等等之类的东西,总之提示什么NO XXXX found,就去安装XXXX-dev或xxxx-devel。

编译就是一件折磨人的事,我不得不说,编译就是开发者偷懒把工作推给用户的行为。 :em06
我按照这个
git clone git://git.gnome.org/gtk+
git clone git://git.gnome.org/glib
后,发现还是没有用阿。
这个是不是只是下载下来了gtk glib,然后还要安装呢?
请问是下载到什么地方去了?
不能apt-get install 么?
不能,现在是我 git clone 了170MB的gtk 和80MB(好像)的glib,不晓得有什么用了,而且也不晓得这个源码弄到哪里去了。我是第一次用这个 git clone
头像
zerroking
帖子: 104
注册时间: 2006-05-12 18:03
来自: 湖北
送出感谢: 3 次
接收感谢: 0

Re: 安装tar.gz包出问题。请教!

#11

帖子 zerroking » 2011-01-04 20:32

不了解为什么要用git而不能用apt-get,我编译软件还没用过git,源码都是从官网手动拖的。
头像
funiculy
帖子: 140
注册时间: 2010-10-13 7:44
送出感谢: 0
接收感谢: 0

Re: 安装tar.gz包出问题。请教!

#12

帖子 funiculy » 2011-01-04 20:38

zerroking 写了:不了解为什么要用git而不能用apt-get,我编译软件还没用过git,源码都是从官网手动拖的。
sudo apt-get install 是这样
screenshot2.png
screenshot2.png (24.72 KiB) 查看 502 次
所以才用的git
头像
zerroking
帖子: 104
注册时间: 2006-05-12 18:03
来自: 湖北
送出感谢: 3 次
接收感谢: 0

Re: 安装tar.gz包出问题。请教!

#13

帖子 zerroking » 2011-01-04 20:45

funiculy 写了:
zerroking 写了:不了解为什么要用git而不能用apt-get,我编译软件还没用过git,源码都是从官网手动拖的。
sudo apt-get install 是这样
screenshot2.png
所以才用的git
新立得里搜一下glib-devel、gtk+-devel等等之类的东西,总之提示什么NO XXXX found,就去安装XXXX-dev或xxxx-devel。

楼主你不看我上面写的吗?你应该安装的是apt-get install glib-devel这个样子啊?
头像
zerroking
帖子: 104
注册时间: 2006-05-12 18:03
来自: 湖北
送出感谢: 3 次
接收感谢: 0

Re: 安装tar.gz包出问题。请教!

#14

帖子 zerroking » 2011-01-04 20:52

刚刚自己去找了一下,如果没有glib-devel的话,请装libglib[版本]-dev试一下,gtk同理,找不到就搜libgtk之类的。

所以我说编译很折磨人的就是这里,它永远不告诉你它缺少的文件的具体名字。你如果没有经验,只能不停的试。
头像
funiculy
帖子: 140
注册时间: 2010-10-13 7:44
送出感谢: 0
接收感谢: 0

Re: 安装tar.gz包出问题。请教!

#15

帖子 funiculy » 2011-01-04 23:31

zerroking 写了:刚刚自己去找了一下,如果没有glib-devel的话,请装libglib[版本]-dev试一下,gtk同理,找不到就搜libgtk之类的。

所以我说编译很折磨人的就是这里,它永远不告诉你它缺少的文件的具体名字。你如果没有经验,只能不停的试。
可以了,终于是成功了。谢谢!
回复

回到 “老旧版本支持”