apt-get 使用出错为啥总是提示上一次的信息?

为当前最终发行版之前的所有版本提供支持
回复
Messiya
帖子: 61
注册时间: 2009-12-02 15:49
送出感谢: 0
接收感谢: 0

apt-get 使用出错为啥总是提示上一次的信息?

#1

帖子 Messiya » 2011-01-05 10:58

The following packages have unmet dependencies:
libcurl3 : Depends: libkrb53 (>= 1.6.dfsg.2) but it is not installable
Depends: libssh2-1 but it is not installed
virtualbox-4.0 : Depends: libqt4-network (>= 4:4.5.3) but it is not installed
Depends: libqt4-opengl (>= 4:4.5.3) but it is not installed
Depends: libqtcore4 (>= 4:4.7.0~beta1) but it is not installed
Depends: libqtgui4 (>= 4:4.7.0~beta1) but it is not installed
Depends: libsdl1.2debian (>= 1.2.10-1) but it is not installed
Recommends: libsdl-ttf2.0-0 but it is not installed
Recommends: dkms but it is not installed
Recommends: libhal1 (>= 0.5) but it is not installed
Recommends: pdf-viewer


我install别的包,也提示这些信息。
头像
pocoyo
论坛版主
帖子: 25878
注册时间: 2008-03-25 15:49
来自: 谁知道?
送出感谢: 5 次
接收感谢: 9 次
联系:

Re: apt-get 使用出错为啥总是提示上一次的信息?

#2

帖子 pocoyo » 2011-01-05 11:13

我还是喜欢用新立得管理。
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

Re: apt-get 使用出错为啥总是提示上一次的信息?

#3

帖子 eexpress » 2011-01-05 11:17

多使用aptitude
● 鸣学
头像
hiphen
帖子: 803
注册时间: 2010-08-27 15:53
送出感谢: 0
接收感谢: 1 次

Re: apt-get 使用出错为啥总是提示上一次的信息?

#4

帖子 hiphen » 2011-01-05 14:14

我推测是上一次的依赖关系尚未清理,
你使用新立得或aptitude的界面清理一下旧依赖试试
基础问题,请看入门手册http://people.ubuntu.com/~happyaron/udc-cn/lucid-html/

Acer aspire 4736G / Ubuntu 10.04LTS
Asus eeepc900 / Xandros
Nokia N900 / Maemo 1.2.12
回复

回到 “老旧版本支持”