Ubuntu 10.10 启动画面丢失,求助。

为当前最终发行版之前的所有版本提供支持
回复
runningwaterpro
帖子: 65
注册时间: 2010-05-15 7:54
送出感谢: 0
接收感谢: 0

Ubuntu 10.10 启动画面丢失,求助。

#1

帖子 runningwaterpro » 2011-01-06 15:52

Ubuntu 启动画面丢失,表现为:屏幕左上角有一个下划线形状的光标闪烁,过后就变成了登录界面。
请问如何找回正常的启动画面,就是下图那样的点状进度条。
图片

update@2011-02-24 后面有一些解决方法,当时认为是解决了,其实没有,防止误导别人,特意过来更新一下。目前对这个问题的认识是:因为系统使用了 nvidia 的闭源驱动,且这个驱动不支持 KMS,Plymouth 恰恰使用 KMS 来输出画面,所以无法正常显示启动画面,这个似乎目前还没有什么好的解决办法。下面的办法仅用于 Intel 和 ATI 显卡。
上次由 runningwaterpro 在 2011-02-24 9:09,总共编辑 1 次。
flac
帖子: 408
注册时间: 2009-05-29 15:21
送出感谢: 2 次
接收感谢: 1 次

Re: Ubuntu 10.10 启动画面丢失,求助。

#2

帖子 flac » 2011-01-06 16:08

/boot/grub/grub.cfg里
linux /vmlinuz-2.6.35-22-generic root=/dev/sda2 ro quiet splash
后面加个splash就可以了
runningwaterpro
帖子: 65
注册时间: 2010-05-15 7:54
送出感谢: 0
接收感谢: 0

Re: Ubuntu 10.10 启动画面丢失,求助。

#3

帖子 runningwaterpro » 2011-01-07 7:59

zdon 写了:/boot/grub/grub.cfg里
linux /vmlinuz-2.6.35-22-generic root=/dev/sda2 ro quiet splash
后面加个splash就可以了
好,谢谢 ,晚上我试试。
runningwaterpro
帖子: 65
注册时间: 2010-05-15 7:54
送出感谢: 0
接收感谢: 0

Re: Ubuntu 10.10 启动画面丢失,求助。

#4

帖子 runningwaterpro » 2011-01-08 10:38

zdon 写了:/boot/grub/grub.cfg里
linux /vmlinuz-2.6.35-22-generic root=/dev/sda2 ro quiet splash
后面加个splash就可以了
你好,里面本身就有 splash 字样,现在还是不显示启动画面。
头像
Ubuntu与Linux
帖子: 1211
注册时间: 2010-06-09 19:57
送出感谢: 2 次
接收感谢: 9 次

Re: Ubuntu 10.10 启动画面丢失,求助。

#5

帖子 Ubuntu与Linux » 2011-01-08 11:05

echo FRAMEBUFFER=y | sudo tee /etc/initramfs-tools/conf.d/splash
sudo update-initramfs -u试试
头像
acid303
帖子: 547
注册时间: 2009-04-03 16:06
送出感谢: 1 次
接收感谢: 2 次

Re: Ubuntu 10.10 启动画面丢失,求助。

#6

帖子 acid303 » 2011-01-08 11:28

wiki -- 速配指南 -- 调整Plymouth启动画面分辨率,倒数第二段
runningwaterpro
帖子: 65
注册时间: 2010-05-15 7:54
送出感谢: 0
接收感谢: 0

Re: Ubuntu 10.10 启动画面丢失,求助。

#7

帖子 runningwaterpro » 2011-01-08 12:17

Ubuntu与Linux 写了:echo FRAMEBUFFER=y | sudo tee /etc/initramfs-tools/conf.d/splash
sudo update-initramfs -u试试
有一定效果了,启动画面是文字的,上面是ubuntu,下面是四个点,谢谢~
runningwaterpro
帖子: 65
注册时间: 2010-05-15 7:54
送出感谢: 0
接收感谢: 0

Re: Ubuntu 10.10 启动画面丢失,求助。

#8

帖子 runningwaterpro » 2011-01-08 12:20

acid303 写了:wiki -- 速配指南 -- 调整Plymouth启动画面分辨率,倒数第二段
按照这个方法,解决了,现在是图形的启动界面了,位便于其他人解决这个问题,直接把那个操作说明贴上了。
调整Plymouth启动画面分辨率
Ubuntu 10.04使用plymouth软件包提供系统启动画面,如果在安装完成后发现启动画面分辨率不高,可以用下面的做法提高分辨率:(以下内容引自http://www.sucka.net/2010/03/nvidia-drivers-ub ... ucid-lynx/)

第一步:打开终端,修改/etc/default/grub文件

$ sudo gedit /etc/default/grub

取消#GRUB_GFXMODE=640×480这一行前面的注释符号,并将后面的数字修改为一个合适的值,不需要太高,比如1024x768。这个值同时会影响grub启动菜单和控制台里文字的分辨率。

第二步:修改/etc/grub.d/00_header文件

$ sudo gedit /etc/grub.d/00_header

按下ctrl+F,查找关键字"set gfxmode=${GRUB_GFXMODE}"(去掉双引号),然后在这行下面添加新行,内容是:"set gfxpayload=keep" (去掉双引号)

第三步:更新grub

$ sudo update-grub

好了,重启试试吧,不出意外的话你会看到plymouth的启动画面确实更漂亮了。

此外,修改前我这里的10.04启动的时候,按下grub菜单后,总是会看到黒屏幕和一个快速闪烁的光标,然后才是启动画面,修改之后黒屏幕没有再出现。
头像
xdtianyu
帖子: 2
注册时间: 2011-01-09 17:51
送出感谢: 0
接收感谢: 0

Re: Ubuntu 10.10 启动画面丢失,求助。

#9

帖子 xdtianyu » 2011-01-19 20:39

runningwaterpro 写了:
acid303 写了:wiki -- 速配指南 -- 调整Plymouth启动画面分辨率,倒数第二段
按照这个方法,解决了,现在是图形的启动界面了,位便于其他人解决这个问题,直接把那个操作说明贴上了。
调整Plymouth启动画面分辨率
Ubuntu 10.04使用plymouth软件包提供系统启动画面,如果在安装完成后发现启动画面分辨率不高,可以用下面的做法提高分辨率:(以下内容引自http://www.sucka.net/2010/03/nvidia-drivers-ub ... ucid-lynx/)

第一步:打开终端,修改/etc/default/grub文件

$ sudo gedit /etc/default/grub

取消#GRUB_GFXMODE=640×480这一行前面的注释符号,并将后面的数字修改为一个合适的值,不需要太高,比如1024x768。这个值同时会影响grub启动菜单和控制台里文字的分辨率。

第二步:修改/etc/grub.d/00_header文件

$ sudo gedit /etc/grub.d/00_header

按下ctrl+F,查找关键字"set gfxmode=${GRUB_GFXMODE}"(去掉双引号),然后在这行下面添加新行,内容是:"set gfxpayload=keep" (去掉双引号)

第三步:更新grub

$ sudo update-grub

好了,重启试试吧,不出意外的话你会看到plymouth的启动画面确实更漂亮了。

此外,修改前我这里的10.04启动的时候,按下grub菜单后,总是会看到黒屏幕和一个快速闪烁的光标,然后才是启动画面,修改之后黒屏幕没有再出现。
貌似这样改了以后进控制台也没有光标了
accessun
帖子: 20
注册时间: 2011-02-24 1:22
送出感谢: 0
接收感谢: 0

Re: Ubuntu 10.10 启动画面丢失,求助。

#10

帖子 accessun » 2011-02-26 15:08

mark以下,也出现了同样的问题
头像
xyuzu3
帖子: 81
注册时间: 2010-05-01 10:03
送出感谢: 0
接收感谢: 1 次

Re: Ubuntu 10.10 启动画面丢失,求助。

#11

帖子 xyuzu3 » 2011-04-15 8:42

八楼的方法是对的,我的就是这么解决的,没有出现什么异常,控制台有光标
头像
fang0319
帖子: 628
注册时间: 2011-01-05 14:21
送出感谢: 0
接收感谢: 0

Re: Ubuntu 10.10 启动画面丢失,求助。

#12

帖子 fang0319 » 2011-04-15 9:39

:em04 :em04
O(∩_∩)O
头像
qy117121
论坛版主
帖子: 49876
注册时间: 2007-12-14 13:40
系统: Winbuntu
来自: 志虚国乌由市
送出感谢: 17 次
接收感谢: 333 次
联系:

Re: Ubuntu 10.10 启动画面丢失,求助。

#13

帖子 qy117121 » 2011-04-15 9:49

xyuzu3 写了:八楼的方法是对的,我的就是这么解决的,没有出现什么异常,控制台有光标
渠月 · QY    https://vz.rs/u
本人只会灌水,不负责回答问题

无聊可以点一下→ http://u.nu/ubuntu
回复

回到 “老旧版本支持”