安装libgtk2.0-dev

为当前最终发行版之前的所有版本提供支持
回复
astro
帖子: 35
注册时间: 2006-10-17 17:28
送出感谢: 0
接收感谢: 0

安装libgtk2.0-dev

#1

帖子 astro » 2006-11-14 20:24

你好,我无法安装libgtk2.0-dev: 系统提示
下列的软件包有不能满足的依赖关系:
libgtk2.0-dev: 依赖: libxcursor-dev 但是它将不会被安装
依赖: libxfixes-dev 但是它将不会被安装
E: 无法安装的软件包

但是我装libxfixes-dev系统提示:

libxfixes-dev: 依赖: libxfixes3 (= 1:3.0.1.2-0ubuntu3) 但是 1:4.0-0ubuntu1 正 要被安装

当我装libxfixe3的时候 系统提示已经安装好了。 请问怎么办? 有人知道具体的方法么?
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2006-11-14 21:03

sudo aptitude install libgtk2.0-dev
看它怎么自动解决。
● 鸣学
头像
ByteFish
帖子: 3
注册时间: 2006-04-24 11:13
送出感谢: 0
接收感谢: 0

#3

帖子 ByteFish » 2006-11-22 20:48

我也出现类似依赖问题:
安装libgtk2.0-dev系统提示需要安装libcairo2-dev,安装libcairo2-dev,系统又提示:
libcairo2-dev: Depends: libcairo2 (= 1.0.4-0ubuntu1) but 1.1.10+git20060621-0ubuntu1 is to be installed

aptitude install libgtk2.0-dev 的方式可以将libcairo2降级为1.0.4-0ubuntu1能够解决问题!
谢谢!
头像
bwchaos
帖子: 416
注册时间: 2006-10-19 14:08
来自: 西夏
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 bwchaos » 2007-02-04 15:28

eexpress 写了:sudo aptitude install libgtk2.0-dev
看它怎么自动解决。
原来如此。。。。。。。
apt居然有这么个问题
头像
hyxuzhimin
帖子: 249
注册时间: 2008-05-09 14:14
送出感谢: 0
接收感谢: 0

#5

帖子 hyxuzhimin » 2008-05-23 17:58

aptitude很智能呀。~
头像
aric286
帖子: 943
注册时间: 2007-12-03 9:54
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 aric286 » 2008-07-20 0:42

太智能了,呵呵
回复

回到 “老旧版本支持”