ubuntu安装libpcap出错,求助!

为当前最终发行版之前的所有版本提供支持
回复
4322502
帖子: 1
注册时间: 2011-01-11 20:13
送出感谢: 0
接收感谢: 0

ubuntu安装libpcap出错,求助!

#1

帖子 4322502 » 2011-01-11 20:19

在安装libpcap时,提示要安装m4、bison和flex。
把m4、bison和flex装好后,但是接着安装libpcap时,到make这一步时,却报错:
root@pxchen-desktop:/usr/libpcap-0.9.6# make
bison -y -p pcap_ -d grammar.y
*** %n in writable segment detected ***
make: *** [grammar.c] Broken pipe
请问是哪里出错了,该怎么解决啊?
头像
ubuntu_amateur
帖子: 79
注册时间: 2006-06-10 14:58
来自: China
送出感谢: 0
接收感谢: 0

Re: ubuntu安装libpcap出错,求助!

#2

帖子 ubuntu_amateur » 2011-01-12 23:27

用synatic安装或手动apt-get install不需要make吧。需要make的包一般先./config一下。
回复

回到 “老旧版本支持”