让firefox和电驴真正关联的方法

为当前最终发行版之前的所有版本提供支持
沙湖王
帖子: 109
注册时间: 2011-01-07 0:04
送出感谢: 0
接收感谢: 0

让firefox和电驴真正关联的方法

#1

帖子 沙湖王 » 2011-01-17 1:19

作为一个刚入手ubuntu半个月的人来说,有许许多多纠结的事情,其中一个就是电驴里面的东西不能下载了,因为关联不了。然后就去网上找各种的方法。找到的基本上都是一样的,我按照那样设置了 ,却根本不能关联。真的,让我很气愤,也很泄气。
今天再次为了下载东西,而找解决的方法,终于找到了这个网站http://www.lirui.name/post/186.html,里面说的方法才是真正的解决方法。
下面把它的东西转过来一下先,这个网站上还有很多的关于ubuntu问题的解决方法,可以去看看。
很多人都发现在Ubuntu 10.04中装好了amule之后无论如何也无法建立与Firefox的关联。在Firefox中添加了两个键以后仍然无法正常从如VeryCD之类的网站正常下载。点击ed2k链接后总是弹出:Firefox 不知道如何打开此地址,因为协议 (ed2k) 未和任何程序关联。



解决方法很简单,请按照如下步骤安装和配置:

在控制台下用如下命令安装amule:

sudo aptitude install amule amule-utils amule-gnome-support

安装完成后按照自己的习惯简单设置一下amule,并读取服务器列表。

然后在Firefox的地址栏输入: about:config

在里面点击鼠标右键新建一个布尔值(Boolean)值,名字是 network.protocol-handler.external.ed2k,值为 true。
再新建一个字符串值(String),名字是network.protocol- handler.app.ed2k,值为 /usr/bin/ed2k 。

然后在Firefox页面中点击一个ed2k链接,会弹出如下对话框:




选中“记住我对ed2k类型链接的选择”,然后确定即可。

Over!
图片没有复制过来,要看原作,就到我发的那个网址上面去看吧
头像
liu滔
帖子: 7211
注册时间: 2010-10-09 23:01
送出感谢: 5 次
接收感谢: 14 次

Re: 让firefox和电驴真正关联的方法

#2

帖子 liu滔 » 2011-01-17 10:47

我以前也是这么设置的,但是到了后来的一次,我自己编译安装了aMule的时候,我发现这个方法失灵了,因为ed2k这个文件再也不是放在/usr/bin里的,所以要改成适当的目录下的ed2k,编译安装的朋友也请记得哦~
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

Re: 让firefox和电驴真正关联的方法

#3

帖子 eexpress » 2011-01-17 11:21

可怜的fx
● 鸣学
头像
tenzu
论坛版主
帖子: 36913
注册时间: 2008-11-21 20:26
送出感谢: 0
接收感谢: 21 次

Re: 让firefox和电驴真正关联的方法

#4

帖子 tenzu » 2011-01-17 11:26

用神器没有这种关联问题?
头像
leeaman
帖子: 30702
注册时间: 2007-02-02 18:14
系统: debian sid
送出感谢: 1 次
接收感谢: 23 次

Re: 让firefox和电驴真正关联的方法

#5

帖子 leeaman » 2011-01-17 11:28

装gnome-support就可以了,不需要那么麻烦的
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)
头像
bcsflilong
帖子: 381
注册时间: 2010-07-24 15:18
系统: ubuntu 16.04.2_amd64
来自: 北京市昌平区昌盛路18号,中国电子科技园
送出感谢: 0
接收感谢: 2 次
联系:

Re: 让firefox和电驴真正关联的方法

#6

帖子 bcsflilong » 2011-01-17 13:19

顶一下吧
life's a struggle
头像
pkuphy
帖子: 53
注册时间: 2010-06-03 9:45
送出感谢: 1 次
接收感谢: 0

Re: 让firefox和电驴真正关联的方法

#7

帖子 pkuphy » 2011-01-17 18:11

tenzu 写了:用神器没有这种关联问题?
何谓神器?
头像
lainme
论坛版主
帖子: 7805
注册时间: 2008-09-13 19:17
系统: Arch Linux (x86_64)
送出感谢: 3 次
接收感谢: 68 次
联系:

Re: 让firefox和电驴真正关联的方法

#8

帖子 lainme » 2011-01-17 18:51

pkuphy 写了:
tenzu 写了:用神器没有这种关联问题?
何谓神器?
opera
头像
张少彬
帖子: 793
注册时间: 2009-07-18 11:33
送出感谢: 1 次
接收感谢: 0

Re: 让firefox和电驴真正关联的方法

#9

帖子 张少彬 » 2011-01-17 20:36

ls正解
神用之器,即为神器
Men are from Mars, I am from the grave
有一次,我去应聘,考官说:“哦,什么味儿?”
我说:”啊,对不起,是我,你知道死人总是有一点味道的“
头像
男菜鸟
帖子: 1169
注册时间: 2008-12-16 14:01
来自: 漂在江湖
送出感谢: 14 次
接收感谢: 15 次

Re: 让firefox和电驴真正关联的方法

#10

帖子 男菜鸟 » 2011-01-17 22:48

mark
头像
liu滔
帖子: 7211
注册时间: 2010-10-09 23:01
送出感谢: 5 次
接收感谢: 14 次

Re: 让firefox和电驴真正关联的方法

#11

帖子 liu滔 » 2011-01-17 22:59

原来opera被称为神器是这个原因啊~
0o永远的菜鸟o0
帖子: 218
注册时间: 2010-12-08 17:10
来自: 宇宙中的某个角落.....
送出感谢: 0
接收感谢: 2 次

Re: 让firefox和电驴真正关联的方法

#12

帖子 0o永远的菜鸟o0 » 2011-01-18 12:13

正准备装,收下了。
我是个完全追求运行速度的人,特效神马的都是浮云...

Ubuntu10.04LTS
坚持单系统,坚持LTS!

PS:有时候我的帖子会没排版,那说明我在用手机上论坛!
levee
帖子: 3030
注册时间: 2009-10-03 23:31
送出感谢: 0
接收感谢: 13 次

Re: 让firefox和电驴真正关联的方法

#13

帖子 levee » 2011-01-18 20:25

amule不叫“电驴”!
头像
astolia
论坛版主
帖子: 3027
注册时间: 2008-09-18 13:11
送出感谢: 1 次
接收感谢: 498 次

Re: 让firefox和电驴真正关联的方法

#14

帖子 astolia » 2011-01-18 21:06

虽然不想打击楼主,但楼主的“真正的解决方法”实际上也是在不懂装懂胡说八道。

修改about:config中的两个设置的方法,只适用于firefox 3.6之前的版本,3.6及后面的版本里,关联程序的方式完全不在about:config里,你写了等于白写。

3.6版及更新版本的关联默认放在~/.mozilla/firefox/XXXXXXXX.default/mimeTypes.rdf里,XXXXXXXX是个随机字符串,这个文件结构相对复杂。在Firefox的设置窗口中可以修改已有的,但不能添加。楼主提到的点击ed2k链接弹出的对话框中实际就是在往那个文件中进行添加。

如果点了还说没有关联程序,很可能是没有装amule-gnome-support。firefox在mimeTypes.rdf中找不到,问gconf也查不到,所以就报错了。如果不想装那个,自己改mimeTypes.rdf也行

总而言之,
如果用firefox 3.5或更早的版本,修改about:config
如果用firefox 3.6或更新的版本,确保amule-gnome-support的安装,点击一个ed2k链接选择关联文件到amule的ed2k程序。如果不想装amule-gnome-support,点击ed2k链接又没有选择关联程序对话框弹出,自己修改mimeTypes.rdf去
头像
AndreaKris
帖子: 79
注册时间: 2010-09-29 12:26
送出感谢: 0
接收感谢: 0

Re: 让firefox和电驴真正关联的方法

#15

帖子 AndreaKris » 2011-04-11 21:22

astolia 写了:虽然不想打击楼主,但楼主的“真正的解决方法”实际上也是在不懂装懂胡说八道。

修改about:config中的两个设置的方法,只适用于firefox 3.6之前的版本,3.6及后面的版本里,关联程序的方式完全不在about:config里,你写了等于白写。

3.6版及更新版本的关联默认放在~/.mozilla/firefox/XXXXXXXX.default/mimeTypes.rdf里,XXXXXXXX是个随机字符串,这个文件结构相对复杂。在Firefox的设置窗口中可以修改已有的,但不能添加。楼主提到的点击ed2k链接弹出的对话框中实际就是在往那个文件中进行添加。

如果点了还说没有关联程序,很可能是没有装amule-gnome-support。firefox在mimeTypes.rdf中找不到,问gconf也查不到,所以就报错了。如果不想装那个,自己改mimeTypes.rdf也行

总而言之,
如果用firefox 3.5或更早的版本,修改about:config
如果用firefox 3.6或更新的版本,确保amule-gnome-support的安装,点击一个ed2k链接选择关联文件到amule的ed2k程序。如果不想装amule-gnome-support,点击ed2k链接又没有选择关联程序对话框弹出,自己修改mimeTypes.rdf去
原来如此!我想呢,改了根本没反应,原来就安装amule-gnome-support就可以了,谢谢噢~
『一语道破』应该就是形容你的这贴吧! :em11
Debian - Squeeze (Xfce)
-
微博: http://t.sina.com.cn/akpan
Twitter: https://twitter.com/andreakpan
最近学习日语中: http://andrea-jplearning.blogbus.com
-
AMD Athlon(tm) 64 X2 Dual Core Processor 4600+ ,2400Ghz
2.00G 的内存
回复

回到 “老旧版本支持”