为 什么我装的 QQ 不能 运行 啊?

为当前最终发行版之前的所有版本提供支持
回复
camgame
帖子: 19
注册时间: 2006-06-26 9:45
送出感谢: 0
接收感谢: 0

为 什么我装的 QQ 不能 运行 啊?

#1

帖子 camgame » 2006-11-15 16:57

运行 时提示 如下 错误 。
是 按照
http://wiki.ubuntu.org.cn/%E5%BF%AB%E9% ... 97/EdgyEft
里 的 步骤安装的,
高手看 看 。谢谢!

./lumaqq
mm@ZJ-07:/opt/LumaQQ$ Exception in thread "main" java.lang.UnsatisfiedLinkError: /opt/LumaQQ/swt/libswt-pi-gtk-3138.so: /opt/LumaQQ/swt/libswt-pi-gtk-3138.so: wrong ELF class: ELFCLASS32
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1751)
at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1676)
at java.lang.Runtime.loadLibrary0(Runtime.java:822)
at java.lang.System.loadLibrary(System.java:993)
at org.eclipse.swt.internal.Library.loadLibrary(Library.java:123)
at org.eclipse.swt.internal.gtk.OS.<clinit>(OS.java:19)
at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:63)
at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:54)
at org.eclipse.swt.widgets.Display.<clinit>(Display.java:122)
at edu.tsinghua.lumaqq.LumaQQ.main(LumaQQ.java:121)
dbzhang800
帖子: 3182
注册时间: 2006-03-10 15:10
来自: xi'an China
送出感谢: 0
接收感谢: 2 次
联系:

#2

帖子 dbzhang800 » 2006-11-15 17:08

代码: 全选

设置当前默认的java解释器

    *

      sudo update-alternatives --config java

          o 执行后会出现类似如下的画面: 

      There are 4 alternatives which provide `java'.
        Selection    Alternative
      -----------------------------------------------
      *+    1        /usr/lib/jvm/java-gcj/jre/bin/java
            2        /usr/bin/gij-wrapper-4.1
            3        /usr/bin/gij-wrapper-4.0
            4        /usr/lib/jvm/java-1.5.0-sun/jre/bin/java
      Press enter to keep the default[*], or type selection number:

      输入 有包含 "sun" 的行的前面的数字。如上面显示,则输入 4,然后回车确定。
这个看了没??
头像
sinoyster
帖子: 958
注册时间: 2005-10-16 13:24
来自: 四川成都
送出感谢: 2 次
接收感谢: 0
联系:

#3

帖子 sinoyster » 2006-11-15 17:42

老弟,你用gcj啦
Thank you Ubuntu Team!!!!
I still can't belive this is free...
camgame
帖子: 19
注册时间: 2006-06-26 9:45
送出感谢: 0
接收感谢: 0

#4

帖子 camgame » 2006-11-16 10:04

我 的 是 这样的
mm@ZJ:~$ sudo update-alternatives --config java

There are 2 alternatives which provide `java'.

Selection Alternative
-----------------------------------------------
1 /usr/bin/gij-wrapper-4.1
*+ 2 /usr/lib/jvm/java-1.5.0-sun/jre/bin/java

Press enter to keep the default[*], or type selection number: 2
Using `/usr/lib/jvm/java-1.5.0-sun/jre/bin/java' to provide `java'.

不 知道会有什么问题?
头像
sinoyster
帖子: 958
注册时间: 2005-10-16 13:24
来自: 四川成都
送出感谢: 2 次
接收感谢: 0
联系:

#5

帖子 sinoyster » 2006-11-16 12:10

不会有什么问题,不过建议再设置一个JAVA_HOME变量,有些程序需要这个
Thank you Ubuntu Team!!!!
I still can't belive this is free...
回复

回到 “老旧版本支持”