一个关于DEB依赖的问题

为当前最终发行版之前的所有版本提供支持
回复
头像
ZENUY
帖子: 55
注册时间: 2009-07-28 22:40
送出感谢: 0
接收感谢: 0

一个关于DEB依赖的问题

#1

帖子 ZENUY » 2011-01-20 17:27

我想安装一个 OSD Lyrics ,从google code 上下载好deb,提示缺少依赖(错误: 依赖关系不满足: libappindicator0 (>= 0.0.19)),用新立得搜索到了这个依赖,装上去(libappindicator0.0-cil),依旧提示错误(错误: 依赖关系不满足: libappindicator0 (>= 0.0.19))。最后去ubuntu软件包列表上搜索了这个软件包并且下载好了这个包
卧槽的事请发生了:
想要安装的包名:libappindicator0.0-cil
提示:错误: 依赖关系不满足: libappindicator0 (>= 0.0.19)
:em20 不说了上图
附件
屏幕截图 - 2011年01月20日 - 17时24分51秒.png
linux世界如同神隐世界一样,带给人对美好生活的向往。
头像
ZENUY
帖子: 55
注册时间: 2009-07-28 22:40
送出感谢: 0
接收感谢: 0

Re: 一个关于DEB依赖的问题

#2

帖子 ZENUY » 2011-01-20 17:28

如有低级错误,敬请指正 :em06
linux世界如同神隐世界一样,带给人对美好生活的向往。
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

Re: 一个关于DEB依赖的问题

#3

帖子 eexpress » 2011-01-20 17:29

不是应该自动依赖的嘛。你去骂那打包deb的。不注明自动依赖。
● 鸣学
头像
lainme
论坛版主
帖子: 7805
注册时间: 2008-09-13 19:17
系统: Arch Linux (x86_64)
送出感谢: 3 次
接收感谢: 68 次
联系:

Re: 一个关于DEB依赖的问题

#4

帖子 lainme » 2011-01-20 18:08

那说明你的源列表里没有这个。是不是不同版本的。比如lucid用10.10的deb包,有时就这样
头像
astolia
论坛版主
帖子: 3153
注册时间: 2008-09-18 13:11
送出感谢: 1 次
接收感谢: 527 次

Re: 一个关于DEB依赖的问题

#5

帖子 astolia » 2011-01-20 19:47

提示缺少libappindicator0,那么软件的名字就是libappindicator0,不要想当然认为是libappindicator0.0-cil
你源里有的应该是libappindicator1了,属于更新版本的。如果你不想自己编译,去这玩意儿的ppa源:https://launchpad.net/~osd-lyrics/+archive/ppa
回复

回到 “老旧版本支持”