大家帮忙解决下swap的问题~~~

为当前最终发行版之前的所有版本提供支持
回复
头像
幻白狼
帖子: 491
注册时间: 2010-05-27 9:28
送出感谢: 0
接收感谢: 1 次

大家帮忙解决下swap的问题~~~

#1

帖子 幻白狼 » 2011-01-29 13:27

昨晚安装oracle,提示我swap分区大小不够~~~
那好吧,我就把swap 删了,然后重新创建一个大一点的
但是悲剧的是,重启以后,我的swap分区,显示如下
swap.png
我用swapon 启动 swap 分区 之后可以了
swapon.png
但是电脑重启之后还是不行
这是怎么个原因??????/

fdisk 显示的信息如下
fdisk.png
fstab 文件显示的信息如下
fstab.png
大家帮帮忙啦~~~谢~~~~
头像
onshoestring
论坛版主
帖子: 4666
注册时间: 2009-09-06 5:53
送出感谢: 0
接收感谢: 108 次

Re: 大家帮忙解决下swap的问题~~~

#3

帖子 onshoestring » 2011-01-29 13:38

可能是楼上说的。
一般改/etc/fstab后,要用mount -a 测试修改有没有问题。
头像
幻白狼
帖子: 491
注册时间: 2010-05-27 9:28
送出感谢: 0
接收感谢: 1 次

Re: 大家帮忙解决下swap的问题~~~

#4

帖子 幻白狼 » 2011-01-29 13:39

photor 写了:新建的swap分区uuid已经变了 :em09
的确,它提示错误的时候总是提到UUID ,那我应该怎么改呢?
:em06
头像
幻白狼
帖子: 491
注册时间: 2010-05-27 9:28
送出感谢: 0
接收感谢: 1 次

Re: 大家帮忙解决下swap的问题~~~

#5

帖子 幻白狼 » 2011-01-29 13:41

onshoestring 写了:可能是楼上说的。
一般改/etc/fstab后,要用mount -a 测试修改有没有问题。
我输入mount -a 的结果


[root@KID kid]# mount -a
[root@KID kid]#
头像
photor
论坛版主
帖子: 11005
注册时间: 2008-04-26 12:41
送出感谢: 8 次
接收感谢: 36 次

Re: 大家帮忙解决下swap的问题~~~

#6

帖子 photor » 2011-01-29 13:46

幻白狼 写了:
photor 写了:新建的swap分区uuid已经变了 :em09
的确,它提示错误的时候总是提到UUID ,那我应该怎么改呢?
:em06
用命令

代码: 全选

sudo blkid
列出swap分区的/dev/sd*设备号,然后在fstab里用这个替换uuid就是 :em09
头像
onshoestring
论坛版主
帖子: 4666
注册时间: 2009-09-06 5:53
送出感谢: 0
接收感谢: 108 次

Re: 大家帮忙解决下swap的问题~~~

#7

帖子 onshoestring » 2011-01-29 13:57

幻白狼 写了:
onshoestring 写了:可能是楼上说的。
一般改/etc/fstab后,要用mount -a 测试修改有没有问题。
我输入mount -a 的结果


[root@KID kid]# mount -a
[root@KID kid]#
应该是swap不用挂载,所以测不出swap的问题。
头像
photor
论坛版主
帖子: 11005
注册时间: 2008-04-26 12:41
送出感谢: 8 次
接收感谢: 36 次

Re: 大家帮忙解决下swap的问题~~~

#8

帖子 photor » 2011-01-29 14:01

onshoestring 写了:
幻白狼 写了:
onshoestring 写了:可能是楼上说的。
一般改/etc/fstab后,要用mount -a 测试修改有没有问题。
我输入mount -a 的结果


[root@KID kid]# mount -a
[root@KID kid]#
应该是swap不用挂载,所以测不出swap的问题。
挂载swap不是用mount,而是用swapon :em09
头像
onshoestring
论坛版主
帖子: 4666
注册时间: 2009-09-06 5:53
送出感谢: 0
接收感谢: 108 次

Re: 大家帮忙解决下swap的问题~~~

#9

帖子 onshoestring » 2011-01-29 14:03

swapon swapoff 知道的 这个应该是启用和停用,swap没有挂载点。
上次由 onshoestring 在 2011-01-29 14:08,总共编辑 1 次。
头像
幻白狼
帖子: 491
注册时间: 2010-05-27 9:28
送出感谢: 0
接收感谢: 1 次

Re: 大家帮忙解决下swap的问题~~~

#10

帖子 幻白狼 » 2011-01-29 14:05

photor 写了:
幻白狼 写了:
photor 写了:新建的swap分区uuid已经变了 :em09
的确,它提示错误的时候总是提到UUID ,那我应该怎么改呢?
:em06
用命令

代码: 全选

sudo blkid
列出swap分区的/dev/sd*设备号,然后在fstab里用这个替换uuid就是 :em09
果然!!!!!!!!!!!!!!
现在好了!!!!!!!!!
哈哈哈哈o(∩∩)o...哈哈
:em11 :em11 :em11 :em11 :em11 :em11
:em38
是不是因为我改建立的新的 UUID 没有被更新到 fstab 里面,所以fstab 里面尝试引导另一块不存在的分区,所以导致了这个错误?
头像
幻白狼
帖子: 491
注册时间: 2010-05-27 9:28
送出感谢: 0
接收感谢: 1 次

Re: 大家帮忙解决下swap的问题~~~

#12

帖子 幻白狼 » 2011-01-29 14:30

photor 写了:是的,你自己新建的swap,fstab是不会自动更新的
明白了,谢谢,第一次用到UUID 呢,感觉这东西挺有意思的~~~ :em05 :em05 :em05
头像
灰色小狼
帖子: 4572
注册时间: 2008-12-06 10:38
系统: Arch
送出感谢: 21 次
接收感谢: 30 次

Re: 大家帮忙解决下swap的问题~~~

#13

帖子 灰色小狼 » 2011-01-29 14:47

来参观学习了 :em05
回复

回到 “老旧版本支持”