/var/lib/dpkg/available 损坏后的办法

为当前最终发行版之前的所有版本提供支持
回复
头像
oneleaf
论坛管理员
帖子: 10208
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 99 次

/var/lib/dpkg/available 损坏后的办法

#1

帖子 oneleaf » 2005-09-20 22:10

今天死机一次,重启发现 /var/lib/dpkg/available 损坏,无法安装包,于是修复:

sudo dselect update

以后就可以再次使用apt-get了.
头像
smallwolf
帖子: 195
注册时间: 2005-09-14 21:39
送出感谢: 0
接收感谢: 0

#2

帖子 smallwolf » 2005-09-20 22:16

谢谢一叶兄共享经验!
头像
catinsnow
帖子: 773
注册时间: 2005-08-02 7:23
来自: 上海
送出感谢: 0
接收感谢: 1 次

#3

帖子 catinsnow » 2005-09-22 17:43

看到debian文档上说,
APT使用/var/lib/apt/lists/*来跟踪可用的软件包,而dpkg使用的是/var/lib/dpkg/available。如果直接用apt-get或同类工具如aptitude等来安装软件包,千万别忘了更新/var/lib/dpkg/available文件,可以使用dselect的[U]pdate选项或在运行dselect update、tasksel或dpkg -l前执行shell命令行“dselect update”。

应该就是这个道理.
Ubuntu Intrepid
#P4 2.4
P4 2.4C
#1024MB
2048MB
#120G
500G+120G
Nvidia FX5700
#ATI9100 --拆了,受不了ATI的驱动.
kgen
帖子: 51
注册时间: 2007-05-28 18:24
送出感谢: 0
接收感谢: 0

#4

帖子 kgen » 2007-08-03 20:32

dingyulong
帖子: 340
注册时间: 2007-02-06 18:12
送出感谢: 0
接收感谢: 0

Re: /var/lib/dpkg/available 损坏后的办法

#5

帖子 dingyulong » 2008-11-21 23:22

我怎么没用,输入后显示:sudo: dselect: command not found
不知怎么,无法更新,报错:
dpkg:buffer_read(fd)中出错:拷贝info文件“/var/lib/dpkg/available":输入输出错误。
附件
Screenshot.png
curflow
帖子: 3
注册时间: 2009-02-23 21:59
送出感谢: 0
接收感谢: 0

Re: /var/lib/dpkg/available 损坏后的办法

#6

帖子 curflow » 2009-03-19 21:28

前面的我都试过不管用,最后是下面这句搞定的
sudo dpkg --clear-avail
然后用下句就没有问题了
sudo apt-get update
头像
geleibo
帖子: 34
注册时间: 2009-01-16 22:02
送出感谢: 0
接收感谢: 0

Re: /var/lib/dpkg/available 损坏后的办法

#7

帖子 geleibo » 2009-06-01 14:38

解决大问题了!!谢谢
人不是每天都年轻
QQ:540938880
E_mail:geleibo@sina.com
头像
geleibo
帖子: 34
注册时间: 2009-01-16 22:02
送出感谢: 0
接收感谢: 0

Re: /var/lib/dpkg/available 损坏后的办法

#8

帖子 geleibo » 2009-08-17 8:05

同时也可以试一下如果命令,我用过,重新配置dpkg数据库,修复依赖关系,重新使用apt-get

sudo dpkg --configure -a

经过一时半会就好了,马上试试
人不是每天都年轻
QQ:540938880
E_mail:geleibo@sina.com
回复

回到 “老旧版本支持”