Edgy的VI不支持语法高亮吗?

为当前最终发行版之前的所有版本提供支持
回复
brucezhao
帖子: 207
注册时间: 2006-10-24 10:37
送出感谢: 0
接收感谢: 0
联系:

Edgy的VI不支持语法高亮吗?

#1

帖子 brucezhao » 2006-11-16 23:12

我设置syntax on时,显示
E319:sorry,the command is not available in this version.

请问如何解决?
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2006-11-17 0:54

VIM - Vi IMproved 7.0 (2006 May 7, compiled Oct 20 2006 09:43:33)
包含补丁: 1-35
● 鸣学
the_owl
帖子: 190
注册时间: 2006-02-18 20:42
送出感谢: 0
接收感谢: 0

#3

帖子 the_owl » 2006-11-17 1:58

我也出现这个问题,后来在新立德里搜索了一下,发现vim这个软件包居然没有安装(但是我一直可以使用vim命令)我想可能是系统默认安装的某个软件里面包含了vim命令。

解决办法是:安装vim这个软件包,然后再设定 syntax on 就可以啦 :D
jun4rui
帖子: 112
注册时间: 2006-10-27 0:13
送出感谢: 0
接收感谢: 0

#4

帖子 jun4rui » 2006-11-17 15:24

vi和vim是两个东西
头像
sinoyster
帖子: 958
注册时间: 2005-10-16 13:24
来自: 四川成都
送出感谢: 2 次
接收感谢: 0
联系:

#5

帖子 sinoyster » 2006-11-17 16:13

sudo apt-get install vim-full
Thank you Ubuntu Team!!!!
I still can't belive this is free...
头像
sinoyster
帖子: 958
注册时间: 2005-10-16 13:24
来自: 四川成都
送出感谢: 2 次
接收感谢: 0
联系:

#6

帖子 sinoyster » 2006-11-17 16:15

edgy只安装了vim-tiny
Thank you Ubuntu Team!!!!
I still can't belive this is free...
brucezhao
帖子: 207
注册时间: 2006-10-24 10:37
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 brucezhao » 2006-11-18 11:08

果然如此,问题解决,感谢楼上的几位。
回复

回到 “老旧版本支持”