遭遇依赖荒

为当前最终发行版之前的所有版本提供支持
回复
头像
pityonline
帖子: 3864
注册时间: 2008-12-09 12:44
来自: 北京
送出感谢: 0
接收感谢: 2 次
联系:

遭遇依赖荒

#1

帖子 pityonline » 2011-02-10 21:18

代码: 全选

pity@online:~$ install xpdf-utils
[sudo] password for pity: 
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
下列软件包是自动安装的并且现在不需要了:
  libmcrypt4 libgringotts2 libmhash2
使用'apt-get autoremove'来删除它们
将会安装下列额外的软件包:
  gsfonts-x11 libt1-5 xpdf-common
下列软件包将被【卸载】:
  bluez-cups cups cups-driver-gutenprint foo2zjs foomatic-db foomatic-db-engine ghostscript-cups
  hplip openprinting-ppds poppler-utils pxljr splix ubuntu-desktop
下列【新】软件包将被安装:
  gsfonts-x11 libt1-5 xpdf-common xpdf-utils
升级了 0 个软件包,新安装了 4 个软件包,要卸载 13 个软件包,有 0 个软件包未被升级。
需要下载 2,275kB 的软件包。
解压缩后将会空出 36.5MB 的空间。
您希望继续执行吗?[Y/n]y
获取:1 http://ubuntu.cn99.com/ubuntu/ lucid/main gsfonts-x11 0.21 [10.5kB]
获取:2 http://ubuntu.cn99.com/ubuntu/ lucid/main libt1-5 5.1.2-3build1 [155kB]
获取:3 http://ubuntu.cn99.com/ubuntu/ lucid-security/universe xpdf-common 3.02-2ubuntu1.1 [69.6kB]
获取:4 http://ubuntu.cn99.com/ubuntu/ lucid-security/universe xpdf-utils 3.02-2ubuntu1.1 [2,040kB]
下载 2,275kB,耗时 14秒 (160kB/s)                                                                  
(正在读取数据库 ... 系统当前总共安装有 273898 个文件和目录。)
正在删除 bluez-cups ...
正在删除 cups-driver-gutenprint ...
 * Reloading Common Unix Printing System: cupsd                                              [ OK ] 
正在删除 splix ...
正在删除 ghostscript-cups ...
正在删除 hplip ...
正在删除 ubuntu-desktop ...
正在删除 pxljr ...
正在删除 openprinting-ppds ...
正在删除 foo2zjs ...
正在删除 foomatic-db ...
正在删除 foomatic-db-engine ...
正在删除 cups ...
 * Stopping Common Unix Printing System: cupsd                                               [ OK ] 
dpkg:poppler-utils:有依赖问题,但是如您所愿还是继续删除:
 impressive 依赖于 poppler-utils | xpdf-reader;然而:
  即将删除 poppler-utils。
  未曾安装软件包“xpdf-reader”。
正在删除 poppler-utils ...
正在处理用于 man-db 的触发器...
正在处理用于 menu 的触发器...
正在处理用于 libc-bin 的触发器...
ldconfig deferred processing now taking place
正在处理用于 desktop-file-utils 的触发器...
正在处理用于 python-gmenu 的触发器...
Rebuilding /usr/share/applications/desktop.zh_CN.utf8.cache...
正在处理用于 ufw 的触发器...
正在处理用于 ureadahead 的触发器...
ureadahead will be reprofiled on next reboot
正在处理用于 doc-base 的触发器...
Processing 1 removed doc-base file(s)...
Registering documents with scrollkeeper...
正在处理用于 python-support 的触发器...
选中了曾被取消选择的软件包 gsfonts-x11。
(正在读取数据库 ... 系统当前总共安装有 268218 个文件和目录。)
正在解压缩 gsfonts-x11 (从 .../gsfonts-x11_0.21_all.deb) ...
选中了曾被取消选择的软件包 libt1-5。
正在解压缩 libt1-5 (从 .../libt1-5_5.1.2-3build1_i386.deb) ...
选中了曾被取消选择的软件包 xpdf-common。
正在解压缩 xpdf-common (从 .../xpdf-common_3.02-2ubuntu1.1_all.deb) ...
选中了曾被取消选择的软件包 xpdf-utils。
正在解压缩 xpdf-utils (从 .../xpdf-utils_3.02-2ubuntu1.1_i386.deb) ...
正在处理用于 fontconfig 的触发器...
正在处理用于 man-db 的触发器...
正在设置 gsfonts-x11 (0.21) ...

正在设置 libt1-5 (5.1.2-3build1) ...

正在设置 xpdf-common (3.02-2ubuntu1.1) ...

正在设置 xpdf-utils (3.02-2ubuntu1.1) ...
正在处理用于 libc-bin 的触发器...
ldconfig deferred processing now taking place

代码: 全选

pity@online:~$ sudo apt-get --purge remove xpdf-utils
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
下列软件包是自动安装的并且现在不需要了:
  python-opengl libgcj-bc libbcmail-java libgfortran3 python-pygame libbcmail-java-gcj
  gcj-4.4-jre-lib libgcj10 libmcrypt4 python-numpy gcj-4.4-base libt1-5 libbcprov-java
  libitext-java libgcj-common libgnumail-java libsdl-ttf2.0-0 libmikmod2 libportmidi0 libblas3gf
  libgnuinet-java libsdl-mixer1.2 liblapack3gf libgringotts2 libmhash2 pdftk libitext-java-gcj
  xpdf-common libgnujaf-java libsmpeg0
使用'apt-get autoremove'来删除它们
下列软件包将被【卸载】:
  impressive* xpdf-utils*
升级了 0 个软件包,新安装了 0 个软件包,要卸载 2 个软件包,有 0 个软件包未被升级。
解压缩后将会空出 5,706kB 的空间。
您希望继续执行吗?[Y/n]n
中止执行。

代码: 全选

pity@online:~$ remove xpdf-utils
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
下列软件包将被【卸载】:
  gcj-4.4-base gcj-4.4-jre-lib impressive libbcmail-java libbcmail-java-gcj libbcprov-java
  libblas3gf libgcj-bc libgcj-common libgcj10 libgfortran3 libgnuinet-java libgnujaf-java
  libgnumail-java libgringotts2 libitext-java libitext-java-gcj liblapack3gf libmcrypt4 libmhash2
  libmikmod2 libportmidi0 libsdl-mixer1.2 libsdl-ttf2.0-0 libsmpeg0 libt1-5 pdftk python-numpy
  python-opengl python-pygame xpdf-common xpdf-utils
升级了 0 个软件包,新安装了 0 个软件包,要卸载 32 个软件包,有 0 个软件包未被升级。
解压缩后将会空出 102MB 的空间。
您希望继续执行吗?[Y/n]n
中止执行。
只是想装个 xpdf-utils 而已,至于搞这么轰动嘛……
Pity is the bomp!
活着就是折腾!生命不息,折腾不止!
看这帮家伙在干什么?@pityonline/u
Dropbox+Vps+PC 跑起来了!这是邀请链接
头像
枫叶饭团
论坛版主
帖子: 14685
注册时间: 2010-06-16 1:05
系统: Mac OS X
来自: Tencent
送出感谢: 1 次
接收感谢: 132 次
联系:

Re: 遭遇依赖荒

#2

帖子 枫叶饭团 » 2011-02-10 21:43

早就习惯了.....
头像
remeber
论坛版主
帖子: 13005
注册时间: 2009-01-06 15:18
来自: 人间
送出感谢: 1 次
接收感谢: 22 次

Re: 遭遇依赖荒

#3

帖子 remeber » 2011-02-11 0:54

:em06
“有一种被人抛诸脑后的过去,包含一些不该遗忘的点点滴滴。欢笑之余,我将故旧拾起,才刹见自己的薄情。人世间似乎存在着某种公平,每个人都曾被抛掷在他人的遗忘中;而今你所有哽咽难宣的话语,也正是你曾为人所期盼,却永远听不见的字句。” —赫曼 赫塞
头像
速腾1994
论坛版主
帖子: 17363
注册时间: 2008-11-01 20:43
系统: Arch+gnome
送出感谢: 23 次
接收感谢: 8 次

Re: 遭遇依赖荒

#4

帖子 速腾1994 » 2011-02-11 0:59

:em04
头像
leeaman
帖子: 30702
注册时间: 2007-02-02 18:14
系统: debian sid
送出感谢: 1 次
接收感谢: 23 次

Re: 遭遇依赖荒

#5

帖子 leeaman » 2011-02-11 9:33

11.04就很常见
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)
回复

回到 “老旧版本支持”