当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 17 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : 好好的硬盘怎么就坏了呢?在BIOS中有时能检测到,有时检测不到。(补了几张图,估计是硬盘坏了。)
帖子发表于 : 2011-02-12 12:39 
头像

注册: 2008-09-26 15:27
帖子: 110
地址: 郑州
送出感谢: 2
接收感谢: 0 次
这个问题我之前在3个比较有名的论坛(个人认为有名,呵呵!)都发了求助贴,一个多月了也没有解决。都说学习Linux要从硬件开始,相信真正的高手在这里,相信我的问题能在这里解决。


我有一个80G的IDE硬盘,去年6月电脑升级之后就扔到一边了。前天找其它东西时看到这块硬盘就想一起挂到电脑里。

之前这块80G的硬盘装的是Ubuntu 9.10的系统,有三个分区:

/ 10G
/swap 2G
/home 剩下全部空间

现在电脑的硬盘是SATA接口,320G,Windows Server 2003系统。

可是当我挂上这个80G的硬盘时等了大概3分钟,电脑才启动。而且进入系统后看不到这块硬盘。

我以为是电脑供电不足,就卸下320G的SATA硬盘。只留这个80G的硬盘和光驱。

重启电脑还是很慢,等到启动了说是找不到系统启动文件,让我插入系统盘(是E文,大概意思是这个)。

后来发现只要是有光驱或是其它硬盘和这个80G的硬盘一起启动都会这样。而且在BIOS中就检测不到这个硬盘。

我以为是之前装的Linux系统坏了,就拨了光驱,只留这个80G的硬盘,然后用U盘做了个Linux系统,从U盘启动进入了系统后能发现这个80G的硬盘。

后来又用U盘做了个WinPE,进入WinPE系统后用磁盘工具检测一下发现这个硬盘的分区竟然是C、D、E、F !而不是我的Linux分区!

于是用工具又低格了一下,低格后又检测了一下硬盘坏道和分区表什么的都没有错误了。才重新装上光驱准备在这个硬盘上做系统。

发现还是和之前一样:

1、只要这个硬盘挂到电脑里,开机很慢,要3-5分钟才能启动,即使电脑里只有这一块硬盘,光驱都不挂也是这样;

2、这个硬盘不能和光驱或是其它硬盘一起挂到电脑里启动,不然在BIOS中就检测不到这块硬盘;

3、用U盘启动可以在BIOS中检测到,而且进入U盘系统后还可以对这个硬盘进行操作(包括复制、粘贴、分区、格式化。。。)。



大家说说这是什么原因?谢谢!

附件:
a.jpg
a.jpg [ 96.54 KiB | 被浏览 9374 次 ]



附件:
b.jpg
b.jpg [ 91.02 KiB | 被浏览 9374 次 ]



附件:
c.jpg
c.jpg [ 65.35 KiB | 被浏览 9374 次 ]



附件:
d.jpg
d.jpg [ 131.04 KiB | 被浏览 9374 次 ]



_________________
大学毕业后,受过高等教育的我对茴香豆的“茴”字的四种写法了如指掌,我牢记孔前辈的话:将来做掌柜的时候,写账要用的~


最后由 towering 编辑于 2011-02-14 8:42,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: 好好的硬盘怎么就坏了呢?在BIOS中有时能检测到,有时检测不到。
帖子发表于 : 2011-02-12 12:50 
头像

注册: 2009-03-28 15:12
帖子: 7867
送出感谢: 2
接收感谢: 20
1、硬盘挂到另一台电脑试试
2、换条排线试试


_________________
Grub2 基础教程


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 好好的硬盘怎么就坏了呢?在BIOS中有时能检测到,有时检测不到。
帖子发表于 : 2011-02-12 12:58 
头像

注册: 2008-09-26 15:27
帖子: 110
地址: 郑州
送出感谢: 2
接收感谢: 0 次
smallapple 写道:
1、硬盘挂到另一台电脑试试
2、换条排线试试



换了电脑和排线还是一样!

谢谢!


_________________
大学毕业后,受过高等教育的我对茴香豆的“茴”字的四种写法了如指掌,我牢记孔前辈的话:将来做掌柜的时候,写账要用的~


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 好好的硬盘怎么就坏了呢?在BIOS中有时能检测到,有时检测不到。
帖子发表于 : 2011-02-12 13:02 
头像

注册: 2009-03-28 15:12
帖子: 7867
送出感谢: 2
接收感谢: 20
mbr清零重置试试。
如果0磁道物理故障无救


_________________
Grub2 基础教程


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 好好的硬盘怎么就坏了呢?在BIOS中有时能检测到,有时检测不到。
帖子发表于 : 2011-02-12 13:16 
头像

注册: 2010-08-26 21:29
帖子: 115
送出感谢: 0 次
接收感谢: 0 次
看不到80g盘:80G那个硬盘和光驱主从跳线冲突了

80g盘速度慢:因为和光驱挂在了同一个IDE接口(还有个原因:SATA刚流行替代IDE那时,有的主板的IDE接口速度变慢,好像芯片组有问题)


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 好好的硬盘怎么就坏了呢?在BIOS中有时能检测到,有时检测不到。
帖子发表于 : 2011-02-12 13:42 
头像

注册: 2008-09-26 15:27
帖子: 110
地址: 郑州
送出感谢: 2
接收感谢: 0 次
Re 4#:

应该不是0磁道物理错误,不然不能进行读写操作。



Re 5#:

卸掉SATA硬盘和光驱,只留这个IDE 80G 还是一样。



谢谢!


_________________
大学毕业后,受过高等教育的我对茴香豆的“茴”字的四种写法了如指掌,我牢记孔前辈的话:将来做掌柜的时候,写账要用的~


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 好好的硬盘怎么就坏了呢?在BIOS中有时能检测到,有时检测不到。
帖子发表于 : 2011-02-12 14:07 
头像

注册: 2009-03-28 15:12
帖子: 7867
送出感谢: 2
接收感谢: 20
towering 写道:
Re 4#:

应该不是0磁道物理错误,不然不能进行读写操作。



这个不是绝对的。如果0磁道没有完全损坏,还能保留分区信息的话,即使在BIOS中完全不能识别,也可以有其他系统中进行读写操作。
如果确实找不出其他原因,可以进行下磁盘坏道检测试试。


_________________
Grub2 基础教程


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 好好的硬盘怎么就坏了呢?在BIOS中有时能检测到,有时检测不到。
帖子发表于 : 2011-02-12 14:39 
头像

注册: 2008-09-26 15:27
帖子: 110
地址: 郑州
送出感谢: 2
接收感谢: 0 次
smallapple 写道:
towering 写道:
Re 4#:

应该不是0磁道物理错误,不然不能进行读写操作。



这个不是绝对的。如果0磁道没有完全损坏,还能保留分区信息的话,即使在BIOS中完全不能识别,也可以有其他系统中进行读写操作。
如果确实找不出其他原因,可以进行下磁盘坏道检测试试。



引用:
低格后又检测了一下硬盘坏道和分区表什么的都没有错误了。才重新装上光驱准备在这个硬盘上做系统。


磁盘坏道检测了,没有问题!

谢谢!


_________________
大学毕业后,受过高等教育的我对茴香豆的“茴”字的四种写法了如指掌,我牢记孔前辈的话:将来做掌柜的时候,写账要用的~


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 好好的硬盘怎么就坏了呢?在BIOS中有时能检测到,有时检测不到。
帖子发表于 : 2011-02-12 15:01 
头像

注册: 2009-03-28 15:12
帖子: 7867
送出感谢: 2
接收感谢: 20
:em20 :em20 :em20


_________________
Grub2 基础教程


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 好好的硬盘怎么就坏了呢?在BIOS中有时能检测到,有时检测不到。
帖子发表于 : 2011-02-12 15:15 
头像

注册: 2009-04-10 11:15
帖子: 721
地址: 三民主义国国民权利省我的选择市中共下台镇
送出感谢: 0 次
接收感谢: 14
可能真的物理损坏了,我的硬盘摔了后就是这样,不要实验了,硬盘是会坏的。
而且坏就了就用不了。


_________________
强烈反对M$的ARM Secure Boot 锁定要求,大家请签名反对
http://www.fsf.org/campaigns/secure-boo ... cted-boot/


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 好好的硬盘怎么就坏了呢?在BIOS中有时能检测到,有时检测不到。
帖子发表于 : 2011-02-13 0:31 
头像

注册: 2008-11-01 20:43
帖子: 17331
系统: Arch+gnome
送出感谢: 44
接收感谢: 11
wubi?
换个电脑?


_________________
谁是我?KL.Uiq8 YinMeng


页首
 用户资料  
 
12 楼 
 文章标题 : Re: 好好的硬盘怎么就坏了呢?在BIOS中有时能检测到,有时检测不到。
帖子发表于 : 2011-02-13 14:54 
头像

注册: 2007-11-25 13:29
帖子: 7342
地址: 新疆博乐
系统: 14.04/16.04/Fedroa22
送出感谢: 38
接收感谢: 102
换机子还不行,不懂了


_________________
===新手请看===
Ubuntu 安装 | Ubuntu12.04/14.04/16.04 桌面操作指南
··Ubuntu16.04 安装图文教程(超简单)
····有时间就静下心来——折腾:)


页首
 用户资料  
 
13 楼 
 文章标题 : Re: 好好的硬盘怎么就坏了呢?在BIOS中有时能检测到,有时检测不到。(补了几张图,估计是硬盘坏了。)
帖子发表于 : 2011-02-14 21:14 
头像

注册: 2007-10-24 20:20
帖子: 1565
地址: 北京、海淀
送出感谢: 0 次
接收感谢: 1
80G硬盘的跳线设置在什么位置了


_________________
Dell Vostro 1500, T7300/4GB/WD5000BEVT/nVidia 8400GM, Ubuntu 10.04 x86_64/VMware 7(Win7)
我的博客:http://xieshaohu.wordpress.com/


页首
 用户资料  
 
14 楼 
 文章标题 : Re: 好好的硬盘怎么就坏了呢?在BIOS中有时能检测到,有时检测不到。(补了几张图,估计是硬盘坏了。)
帖子发表于 : 2011-02-15 15:21 
头像

注册: 2008-09-26 15:27
帖子: 110
地址: 郑州
送出感谢: 2
接收感谢: 0 次
xieshaohu 写道:
80G硬盘的跳线设置在什么位置了



应该不是跳线的问题。

估计就是硬盘不行了。

你看第一张图的“当前”和“最差”两个选项卡,基本都是最差了。


_________________
大学毕业后,受过高等教育的我对茴香豆的“茴”字的四种写法了如指掌,我牢记孔前辈的话:将来做掌柜的时候,写账要用的~


页首
 用户资料  
 
15 楼 
 文章标题 : Re: 好好的硬盘怎么就坏了呢?在BIOS中有时能检测到,有时检测不到。(补了几张图,估计是硬盘坏了。)
帖子发表于 : 2011-02-15 16:02 
头像

注册: 2008-01-12 14:11
帖子: 303
送出感谢: 0 次
接收感谢: 0 次
数据线问题,看看数据线是不是接反了,我也是SATA+IDE(硬盘)+IDE(光驱),一点问题都没有。最好把主板BIOS升级到最新。BIOS里有个硬盘设置,好象是P+SATA和Enhanced两选项,我的是P+SATA,还有个检测超时,我的20秒


_________________
Ubuntu 11.04


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 17 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
cron
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译