SCIM1.4安装失败

为当前最终发行版之前的所有版本提供支持
回复
earlzhang
帖子: 19
注册时间: 2005-09-18 17:47
送出感谢: 0
接收感谢: 0

SCIM1.4安装失败

#1

帖子 earlzhang » 2005-09-21 1:29

小弟从scim-im.org下载了最新1.4版的源码,希望升级一下ubuntu自带的旧版本。但是执行第一步就出错,系统显示

代码: 全选

checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... no
checking whether NLS is requested... yes
checking for msgfmt... no
checking for gmsgfmt... :
checking for xgettext... no
checking for msgmerge... no
checking for style of include used by make... none
checking for gcc... gcc
checking for C compiler default output file name... configure: error: C compiler  cannot create executables
See `config.log' for more details.

不知道这是怎么回事?应该怎样解决才好?
头像
smallwolf
帖子: 195
注册时间: 2005-09-14 21:39
送出感谢: 0
接收感谢: 0

#2

帖子 smallwolf » 2005-09-21 8:15

对编译源码不太懂,不过从你给出的信息,可以看出,应该是no的地方使编译失败的

而且编译源码需要先 ./configure 不知你进行这一步了吗?

达人请进,我也搭车学习
头像
yonsan
帖子: 887
注册时间: 2005-07-01 18:56
来自: 广州市
送出感谢: 0
接收感谢: 3 次

#3

帖子 yonsan » 2005-09-21 8:53

:o
安装

代码: 全选

sudo apt-get install autoconf automake1.7 autotools-dev build-essential dpatch g++ g++-3.3 gcc gcc-3.3 indent intltool libatk1.0-dev libexpat1-dev libfontconfig1-dev libfreetype6-dev libgconf2-dev libglib2.0-dev libgtk2.0-dev libhtml-parser-perl libhtml-tagset-perl libhtml-tree-perl libice-dev libidl-dev liborbit2-dev libpango1.0-dev libpopt-dev libsm-dev libstdc++5-3.3-dev liburi-perl libwww-perl libx11-dev libxau-dev libxext-dev libxft-dev libxi-dev libxkbfile-dev libxml-parser-perl libxmu-dev libxmuu-dev libxp-dev libxpm-dev libxrandr-dev libxrender-dev libxt-dev libxtrap-dev libxtst-dev libxv-dev pm-dev render-dev x-dev xlibs-dev xlibs-static-dev zlib1g-dev fakeroot patchutils orbit2 libmailtools-perl libhtml-format-perl libcompress-zlib-perl

才编译scim-1.4源码
I will be back!
头像
smallwolf
帖子: 195
注册时间: 2005-09-14 21:39
送出感谢: 0
接收感谢: 0

#4

帖子 smallwolf » 2005-09-21 10:29

@@

晕厥吐血.......

天啊 编译源码这么麻烦啊

还是装deb包吧

偶是懒人 :)
回复

回到 “老旧版本支持”