当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : ubuntu10.10挂载window 分区出现的问题。。困扰很久。。
帖子发表于 : 2011-02-18 7:05 
头像

注册: 2011-02-17 5:23
帖子: 10
地址: West Lafayette
送出感谢: 0 次
接收感谢: 0 次
板上各位大仙:

我的电脑是lenovo Y450 laptop,以前一直是xp系统,C盘系统,然后还有D,E,F盘
最近刚撞了ubuntu10.10,装在了D盘,D盘里原来还有一些文档资料什么的,现在想挂载windows分区,结果出现了问题:D盘下的部分文件夹在ubuntu下怎么都找不到,好像消失了一样
我run了df -h:
文件系统 容量 已用 可用 已用%% 挂载点
/dev/loop0 4.6G 3.0G 1.5G 68% /
none 999M 300K 999M 1% /dev
none 1004M 256K 1004M 1% /dev/shm
none 1004M 100K 1004M 1% /var/run
none 1004M 0 1004M 0% /var/lock
/dev/sda6 98G 72G 27G 73% /media/M_fM__\M_,M_eM__\M_0M_gM_#M__AM_gM__[M__X
/dev/sda5 89G 44G 46G 49% /host
/dev/sda1 24G 16G 8.2G 66% /media/sda1
/dev/sda7 89G 59G 30G 67% /media/sda7

然后run了fdisk -l,结果是:
Device Boot Start End Blocks Id System
/dev/sda1 * 1 3060 24579418+ 7 HPFS/NTFS
/dev/sda2 3061 38913 287989222+ f W95 Ext'd (LBA)
/dev/sda5 3061 14661 93185001 7 HPFS/NTFS
/dev/sda6 14662 27409 102398278+ 7 HPFS/NTFS
/dev/sda7 27410 38913 92405848+ 7 HPFS/NTFS

完全一头雾水。。。而且为什么会出现/M_fM__\M_,M_eM__\M_0M_gM_#M__AM_gM__[M__X这样的名字啊。。。
我也安装了NTSF写入支持程序,

加入我想在高级配置中卸载其中一个,比如sad6:就会出现一个对话框卸载 /media/M_fM__\M_,M_eM__\M_0M_gM_#M__AM_gM__[M__X 失败,因为出现如下错误:umount: /media/M_fM__M_,M_eM__M_0M_gM_#M__AM_gM__[M__X: 找不到
想挂载一个的话,又会出现对话框:挂载 /media/M_fM__\134M_,M_eM__\134M_0M_gM_#M__AM_gM__[M__X失败,因为发生如下错误:Mount is denied because the NTFS volume is already exclusively opened.
The volume may be already mounted, or another software may use it which
could be identified for example by the help of the 'fuser' command.

有没有人能帮我下看看我到底是什么问题啊。。 :em20


附件:
文件注释: 截屏
Screenshot.png
Screenshot.png [ 66.29 KiB | 被浏览 2411 次 ]



_________________
为了想要的东西,热情和投资都是有必要的
页首
 用户资料  
 
2 楼 
 文章标题 : Re: ubuntu10.10挂载window 分区出现的问题。。困扰很久。。
帖子发表于 : 2011-02-18 7:40 
头像

注册: 2010-11-05 22:44
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
是什么文件夹呢?~ 可能是WINDOWS的硬连接吧


页首
 用户资料  
 
3 楼 
 文章标题 : Re: ubuntu10.10挂载window 分区出现的问题。。困扰很久。。
帖子发表于 : 2011-02-18 7:52 
头像

注册: 2011-02-17 5:23
帖子: 10
地址: West Lafayette
送出感谢: 0 次
接收感谢: 0 次
tecz 写道:
是什么文件夹呢?~ 可能是WINDOWS的硬连接吧

是自己的一些工作文档。。。


_________________
为了想要的东西,热情和投资都是有必要的


页首
 用户资料  
 
4 楼 
 文章标题 : Re: ubuntu10.10挂载window 分区出现的问题。。困扰很久。。
帖子发表于 : 2011-02-18 9:39 
头像

注册: 2009-03-28 15:12
帖子: 7867
送出感谢: 2
接收感谢: 20
把分区中文卷标改为英文的。


_________________
Grub2 基础教程


页首
 用户资料  
 
5 楼 
 文章标题 : Re: ubuntu10.10挂载window 分区出现的问题。。困扰很久。。
帖子发表于 : 2011-02-18 10:31 
头像

注册: 2011-02-17 5:23
帖子: 10
地址: West Lafayette
送出感谢: 0 次
接收感谢: 0 次
smallapple 写道:
把分区中文卷标改为英文的。

这个是我的fstab:

# <file system> <mount point> <type> <options> <dump> <pass>

proc /proc proc nodev,noexec,nosuid 0 0
/dev/sda5 /host ntfs-3g defaults,nosuid,nodev,locale=zh_CN.UTF-8 0 0
/dev/sda6 /media/M_fM__\134M_,M_eM__\134M_0M_gM_#M__AM_gM__[M__X ntfs-3g defaults,nosuid,nodev,locale=zh_CN.UTF-8 0 0
/dev/sda6 /media/M_fM__\M_,M_eM__\M_0M_gM_#M__AM_gM__[M__X ntfs-3g defaults,locale=zh_CN.UTF-8 0 0
/dev/sda1 /media/sda1 ntfs-3g defaults,locale=zh_CN.UTF-8 0 0
/dev/sda7 /media/sda7 ntfs-3g defaults,locale=zh_CN.UTF-8 0 0
/dev/sda1 /windows/sda1 ntfs-3g defaults,auto,user,locale=zh_CN.UTF-8 0 0
/dev/sda5 /windows/sda5 ntfs-3g defaults,auto,user,locale=zh_CN.UTF-8 0 0
/dev/sda6 /windows/sda6 ntfs-3g defaults,auto,user,locale=zh_CN.UTF-8 0 0
/dev/sda7 /windows/sda7 ntfs-3g defaults,auto,user,locale=zh_CN.UTF-8 0 0
/host/ubuntu/disks/root.disk / ext4 loop,errors=remount-ro 0 1
/host/ubuntu/disks/swap.disk none swap loop,sw 0 0

我先前不小心删了一行什么。。。然后每次开机关机就告诉我"an error occurred while mounting /windows/sda6, 关机的时候swap就提示“fail”你能帮我看看我应该怎么加句话命令进去吗?谢谢!
下面是我的uuid:(其实应该没用,我也没分区过,也没自己重新弄swap过,但是估计就是我删了某一行之后fstab出问题了)
/dev/loop0: UUID="030645c6-3b61-4818-b137-4fe3e340a041" TYPE="ext4"
/dev/sda1: LABEL="System" UUID="300C1B2B0C1AEC1A" TYPE="ntfs"
/dev/sda5: LABEL="Study" UUID="2834A4AB34A47E06" TYPE="ntfs"
/dev/sda6: LABEL="Movie" UUID="26A0ABEDA0ABC1A3" TYPE="ntfs"
/dev/sda7: LABEL="Software" UUID="8464B22464B2193E" TYPE="ntfs"


_________________
为了想要的东西,热情和投资都是有必要的


页首
 用户资料  
 
6 楼 
 文章标题 : Re: ubuntu10.10挂载window 分区出现的问题。。困扰很久。。
帖子发表于 : 2011-02-18 12:11 
头像

注册: 2009-03-28 15:12
帖子: 7867
送出感谢: 2
接收感谢: 20
把重复的挂载项先删除再看看
/dev/sda6 /media/M_fM__\134M_,M_eM__\134M_0M_gM_#M__AM_gM__[M__X ntfs-3g defaults,nosuid,nodev,locale=zh_CN.UTF-8 0 0
/dev/sda6 /media/M_fM__\M_,M_eM__\M_0M_gM_#M__AM_gM__[M__X ntfs-3g defaults,locale=zh_CN.UTF-8 0 0
/dev/sda1 /media/sda1 ntfs-3g defaults,locale=zh_CN.UTF-8 0 0
/dev/sda7 /media/sda7 ntfs-3g defaults,locale=zh_CN.UTF-8 0 0
/dev/sda5 /windows/sda5 ntfs-3g defaults,auto,user,locale=zh_CN.UTF-8 0 0
把上面这几行先删除,wubi安装的那个 /sda5 要挂在 /host,不要修改。


_________________
Grub2 基础教程


页首
 用户资料  
 
7 楼 
 文章标题 : Re: ubuntu10.10挂载window 分区出现的问题。。困扰很久。。
帖子发表于 : 2011-02-19 1:46 
头像

注册: 2011-02-17 5:23
帖子: 10
地址: West Lafayette
送出感谢: 0 次
接收感谢: 0 次
smallapple 写道:
把重复的挂载项先删除再看看
/dev/sda6 /media/M_fM__\134M_,M_eM__\134M_0M_gM_#M__AM_gM__[M__X ntfs-3g defaults,nosuid,nodev,locale=zh_CN.UTF-8 0 0
/dev/sda6 /media/M_fM__\M_,M_eM__\M_0M_gM_#M__AM_gM__[M__X ntfs-3g defaults,locale=zh_CN.UTF-8 0 0
/dev/sda1 /media/sda1 ntfs-3g defaults,locale=zh_CN.UTF-8 0 0
/dev/sda7 /media/sda7 ntfs-3g defaults,locale=zh_CN.UTF-8 0 0
/dev/sda5 /windows/sda5 ntfs-3g defaults,auto,user,locale=zh_CN.UTF-8 0 0
把上面这几行先删除,wubi安装的那个 /sda5 要挂在 /host,不要修改。

啊,谢谢!
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>

proc /proc proc nodev,noexec,nosuid 0 0
/dev/sda5 /host ntfs-3g defaults,nosuid,nodev,locale=zh_CN.UTF-8 0 0
/dev/sda1 /windows/sda1 ntfs-3g defaults,auto,user,locale=zh_CN.UTF-8 0 0
/dev/sda6 /windows/sda6 ntfs-3g defaults,auto,user,locale=zh_CN.UTF-8 0 0
/dev/sda7 /windows/sda7 ntfs-3g defaults,auto,user,locale=zh_CN.UTF-8 0 0
/host/ubuntu/disks/root.disk / ext4 loop,errors=remount-ro 0 1
/host/ubuntu/disks/swap.disk none swap loop,sw 0 0
现在我的fstab重启后是变成这个样子了,的确没有那些很奇怪的挂载点了。可是还有个问题:我是把ubuntu用wubi装在d盘(一开始我觉得d盘空),d盘大概有80G样子,可是装了之后进入ubuntu,原来D盘下的那些我自己的文件夹什么的怎么都找不到了。。我的机子,sda5应该就是D盘了,我也的确在/windows下看到了我的sda1(c盘),sda6(e盘)和sda7(f盘),sda5有是有,但是点进去是空的,而且只有1G不到的剩余。。这是怎么回事啊?是不是我一旦在一开始把ubuntu装在D盘,那个盘里的其他xp系统下的文档啊什么的东西就不能被挂载了?有没有啥解决办法啊?


附件:
1.jpg
1.jpg [ 38.62 KiB | 被浏览 2233 次 ]



_________________
为了想要的东西,热情和投资都是有必要的
页首
 用户资料  
 
8 楼 
 文章标题 : Re: ubuntu10.10挂载window 分区出现的问题。。困扰很久。。
帖子发表于 : 2011-02-19 9:12 
头像

注册: 2009-03-28 15:12
帖子: 7867
送出感谢: 2
接收感谢: 20
wubi安装的那个 /sda5(就是所谓的D盘)挂在 /host,到 /host下找。


_________________
Grub2 基础教程


页首
 用户资料  
 
9 楼 
 文章标题 : Re: ubuntu10.10挂载window 分区出现的问题。。困扰很久。。
帖子发表于 : 2011-02-20 5:50 
头像

注册: 2011-02-17 5:23
帖子: 10
地址: West Lafayette
送出感谢: 0 次
接收感谢: 0 次
smallapple 写道:
wubi安装的那个 /sda5(就是所谓的D盘)挂在 /host,到 /host下找。

啊果然如此!谢谢你指点。。我搜索了这几天终于把挂载什么的基本概念搞清楚了。。


_________________
为了想要的东西,热情和投资都是有必要的


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Google [Bot] 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译