apt-get update 出现错误

为当前最终发行版之前的所有版本提供支持
回复
头像
smallwolf
帖子: 195
注册时间: 2005-09-14 21:39
送出感谢: 0
接收感谢: 0

apt-get update 出现错误

#1

帖子 smallwolf » 2005-09-21 16:58

guest@ubuntu:~$ sudo apt-get update
E: 无法获得锁 /var/lib/apt/lists/lock - open (11 资源暂时不可用)
E: 无法对状态列表目录加锁

代码: 全选

guest@ubuntu:~$ sudo ls /var/lib/apt/lists/
archive.ubuntu.org.cn_backports_dists_hoary-backports_main_binary-i386_Packages
archive.ubuntu.org.cn_backports_dists_hoary-backports_multiverse_binary-i386_Packages
archive.ubuntu.org.cn_backports_dists_hoary-backports_restricted_binary-i386_Packages
archive.ubuntu.org.cn_backports_dists_hoary-backports_universe_binary-i386_Packages
archive.ubuntu.org.cn_backports_dists_hoary-extras_main_binary-i386_Packages
archive.ubuntu.org.cn_backports_dists_hoary-extras_multiverse_binary-i386_Packages
archive.ubuntu.org.cn_backports_dists_hoary-extras_restricted_binary-i386_Packages
archive.ubuntu.org.cn_backports_dists_hoary-extras_universe_binary-i386_Packages
archive.ubuntu.org.cn_ubuntu-cn_dists_hoary_main_binary-i386_Packages
archive.ubuntu.org.cn_ubuntu-cn_dists_hoary_multiverse_binary-i386_Packages
archive.ubuntu.org.cn_ubuntu-cn_dists_hoary_restricted_binary-i386_Packages
archive.ubuntu.org.cn_ubuntu-cn_dists_hoary_universe_binary-i386_Packages
archive.ubuntu.org.cn_ubuntu_dists_hoary_main_binary-i386_Packages
archive.ubuntu.org.cn_ubuntu_dists_hoary_multiverse_binary-i386_Packages
archive.ubuntu.org.cn_ubuntu_dists_hoary_Release
archive.ubuntu.org.cn_ubuntu_dists_hoary_Release.gpg
archive.ubuntu.org.cn_ubuntu_dists_hoary_restricted_binary-i386_Packages
archive.ubuntu.org.cn_ubuntu_dists_hoary-security_main_binary-i386_Packages
archive.ubuntu.org.cn_ubuntu_dists_hoary-security_multiverse_binary-i386_Packages
archive.ubuntu.org.cn_ubuntu_dists_hoary-security_Release
archive.ubuntu.org.cn_ubuntu_dists_hoary-security_Release.gpg
archive.ubuntu.org.cn_ubuntu_dists_hoary-security_restricted_binary-i386_Packages
archive.ubuntu.org.cn_ubuntu_dists_hoary-security_universe_binary-i386_Packages
archive.ubuntu.org.cn_ubuntu_dists_hoary_universe_binary-i386_Packages
archive.ubuntu.org.cn_ubuntu_dists_hoary-updates_main_binary-i386_Packages
archive.ubuntu.org.cn_ubuntu_dists_hoary-updates_multiverse_binary-i386_Packages
archive.ubuntu.org.cn_ubuntu_dists_hoary-updates_Release
archive.ubuntu.org.cn_ubuntu_dists_hoary-updates_Release.gpg
archive.ubuntu.org.cn_ubuntu_dists_hoary-updates_restricted_binary-i386_Packages
archive.ubuntu.org.cn_ubuntu_dists_hoary-updates_universe_binary-i386_Packages
lock
partial


guest@ubuntu:~$ sudo cat /etc/apt/sources.list
deb http://archive.ubuntu.org.cn/ubuntu hoary main restricted universe multiverse
deb http://archive.ubuntu.org.cn/ubuntu hoary-security main restricted universe multiverse
deb http://archive.ubuntu.org.cn/ubuntu hoary-updates main restricted universe multiverse
deb http://archive.ubuntu.org.cn/ubuntu-cn hoary main universe multiverse restricted
deb http://archive.ubuntu.org.cn/backports hoary-backports main universe multiverse restricted
deb http://archive.ubuntu.org.cn/backports hoary-extras main universe multiverse restricted

这些是基本的情况,问题出现经过:

我看到有新的源,于是就把原来的注释掉了,用新的试试,但新的不好使,我就又删掉了,把原来的注释去掉。

然后再update就出现错误了,请指教!

谢谢!
头像
carlos444_444
帖子: 441
注册时间: 2005-06-06 21:35
系统: Debian
来自: 双子星
送出感谢: 2 次
接收感谢: 2 次
联系:

#2

帖子 carlos444_444 » 2005-09-21 17:09

http://www.ubuntu.org.cn/support/docume ... oc/sources
看看这个,如果它提供的最快的源不好用,就在文件里把那一行删除,然后再运行,找第二快的。有些源似乎没有建立好,软件不齐全。
如果删除最后一个源的话,注意在 /的后面,有一个 \,把这个 \要加到上面的一行,保证语法正确(自然要注意它和引号的位置,看到那个文件就明白了)。
:P
头像
smallwolf
帖子: 195
注册时间: 2005-09-14 21:39
送出感谢: 0
接收感谢: 0

#3

帖子 smallwolf » 2005-09-21 17:17

我去试试先

谢谢!
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 yongyi » 2005-09-21 19:12

E: 无法获得锁 /var/lib/apt/lists/lock - open (11 资源暂时不可用)
-----这是因为你另外打开了apt。比如你打开了新立得。
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
头像
carlos444_444
帖子: 441
注册时间: 2005-06-06 21:35
系统: Debian
来自: 双子星
送出感谢: 2 次
接收感谢: 2 次
联系:

#5

帖子 carlos444_444 » 2005-09-21 20:39

哈哈,这个倒真的没注意
对,apt-get,新立得,还有什么不可以同时用
头像
smallwolf
帖子: 195
注册时间: 2005-09-14 21:39
送出感谢: 0
接收感谢: 0

#6

帖子 smallwolf » 2005-09-21 21:26

谢谢!

已解决

应该是同时运行apt的原因

我更新源后 运行了apt 然后我用ctrl+z停止了 我以为这样进程也被杀掉了

看来应该不是 它还驻留在系统中呢 然后我把源换回来 就不能使用apt了 显示如

前面的错误信息。

又知道一个新知识 :)

谢谢!
回复

回到 “老旧版本支持”