ubuntu10.10 安装flex报错。。。。这是什么问题?

为当前最终发行版之前的所有版本提供支持
回复
a375474942
帖子: 3
注册时间: 2011-02-24 12:45
送出感谢: 0
接收感谢: 0

ubuntu10.10 安装flex报错。。。。这是什么问题?

#1

帖子 a375474942 » 2011-02-24 14:02

jlk@jlk-desktop:~$ sudo apt-get install flex
[sudo] password for jlk:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
flex 已经是最新的版本了。
下列软件包是自动安装的并且现在不需要了:
ttf-droid
使用'apt-get autoremove'来卸载它们
升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件包未被升级。
有 1 个软件包没有被完全安装或卸载。
解压缩后会消耗掉 0B 的额外空间。
您希望继续执行吗?[Y/n]y
正在设置 install-info (4.13a.dfsg.1-5ubuntu1) ...
/etc/environment: line 2:   export:找不到命令
dpkg:处理 install-info (--configure)时出错:
子进程 已安装 post-installation 脚本 返回了错误号 127
在处理时有错误发生:
install-info
E: Sub-process /usr/bin/dpkg returned an error code (1)
sosoinlove
帖子: 30
注册时间: 2010-11-01 11:54
送出感谢: 0
接收感谢: 0

Re: ubuntu10.10 安装flex报错。。。。这是什么问题?

#2

帖子 sosoinlove » 2011-06-24 18:21

1.$ sudo mv /var/lib/dpkg/info /var/lib/dpkg/info_old //现将info文件夹更名
2.$ sudo mkdir /var/lib/dpkg/info //再新建一个新的info文件夹
3.$ sudo apt-get update, apt-get -f install //不用解释了吧
4.$ sudo mv /var/lib/dpkg/info/* /var/lib/dpkg/info_old //执行完上一步操作后会在新的info文件夹下生成一些文件,现将这些文件全部移到info_old文件夹下
5.$ sudo rm -rf /var/lib/dpkg/info //把自己新建的info文件夹删掉
6.$ sudo mv /var/lib/dpkg/info_old /var/lib/dpkg/info //把以前的info文件夹重新改回名字
到此问题顺利解决,哈哈
回复

回到 “老旧版本支持”