交叉编译器问题

为当前最终发行版之前的所有版本提供支持
回复
头像
Destiny_Hot
帖子: 14
注册时间: 2010-08-09 21:01
送出感谢: 0
接收感谢: 0

交叉编译器问题

#1

帖子 Destiny_Hot » 2011-03-06 11:49

交叉编译器问题 开发板 附带了一个交叉编译器 版本很低2.9.* 但可以使用 编译过的程序在板子上能运行
但为了 配合gdbserver 有新安装了一个 arm-linux-gcc-4.3.2 并修改了新的PATH
但这时 编译的程序就不能在板子上运行了?
不知道是什么原因!
难道一台机子上不能存在两个交叉编译器?还是板子不支持高版本的交叉编译起阿?
求讲解!!!
在深渊中挣扎的命运之火
头像
Destiny_Hot
帖子: 14
注册时间: 2010-08-09 21:01
送出感谢: 0
接收感谢: 0

Re: 交叉编译器问题

#2

帖子 Destiny_Hot » 2011-03-06 12:08

而且 PATH 修改成不同的路径 通过 命令
arm-linux-gcc -v 可以显示两种不同版本的编译器 感觉两个不同版本的编译器也没有同时运行 产生什么影响阿

求讲解阿 在线等回复呢 - _ -!
在深渊中挣扎的命运之火
头像
Destiny_Hot
帖子: 14
注册时间: 2010-08-09 21:01
送出感谢: 0
接收感谢: 0

Re: 交叉编译器问题

#3

帖子 Destiny_Hot » 2011-03-06 12:58

还有 就是原来版本 2.9.*的交叉编译器 能编译 但在搭建gdbserver 时会报出很多错误 不会改就放弃了
改装4.3.2之后 在装gdbserver 就不会报错了 直接安装完成了 但编译的程序不能在板子上运行
如果路径换成 老版本的交叉编译器路径 还能进行编译 并且能在板子上执行
说了这么多 应该了解我的情况了把
发表点意见 我试试!
在深渊中挣扎的命运之火
回复

回到 “老旧版本支持”