vim卸载了装不上去了!

为当前最终发行版之前的所有版本提供支持
回复
头像
comoon
帖子: 26
注册时间: 2011-03-05 18:48
送出感谢: 0
接收感谢: 0

vim卸载了装不上去了!

#1

帖子 comoon » 2011-03-09 22:29

我以前用的是ubuntu10.10里面的默认安装的vim,因为不支持语法高亮,我弄了半天,又在网上看了一些方法,都没用,于是乎一个邪恶的念头诞生了,我打算卸载了它 :em03
我先用dpkg -l |grep vim查看了所安装的vim,有3个,然后我用sudo apt-get --purge remove vim--一个个把它们都卸载了, :em09 然后再查看,果然一个都没了,都被我卸载了! :em11
然后我就打算用sudo apt-get install vim-full来完全安装,结果发现出问题了!提示:
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package vim-full :em20
.........”找不到vim-full的软件包?“这个要怎么办?有谁知道么?
其实我也不太了解vim,只是想语法高亮,然后就是输入别那么....你明白的,默认的vim输入我确实还是适应了一段时间的,有点小麻烦的,一个括号一个括号....因该装哪个呢?没必要full?
上次由 comoon 在 2011-03-09 22:32,总共编辑 1 次。
头像
adagio
论坛版主
帖子: 22110
注册时间: 2008-02-17 23:47
来自: 美丽富饶的那啥星球
送出感谢: 7 次
接收感谢: 74 次

Re: vim卸载了装不上去了!

#2

帖子 adagio » 2011-03-09 22:31

sudo apt-get install vim-gtk
明天就换大三八!
——8核CPU、8G内存、8T硬盘……
8卡交火,80寸大屏放8个……
IPv8的光纤要8条……

---------------------------------------------------------------------------------
[图片版]新手当自强(续)FAQ
[新手进阶]挂载、fstab、调整linux分区
[图片版]E17桌面环境配置手把手
头像
comoon
帖子: 26
注册时间: 2011-03-05 18:48
送出感谢: 0
接收感谢: 0

Re: vim卸载了装不上去了!

#3

帖子 comoon » 2011-03-09 22:40

adagio 写了:sudo apt-get install vim-gtk
倒是装上了,没有高亮显示啊,syntax on也没反应!
xjhunter
帖子: 2
注册时间: 2010-10-03 22:50
送出感谢: 0
接收感谢: 0

Re: vim卸载了装不上去了!

#4

帖子 xjhunter » 2011-04-15 9:13

和LZ遇到了一样的问题,语法高亮弄不出来,再研究一下 :em06
头像
fang0319
帖子: 628
注册时间: 2011-01-05 14:21
送出感谢: 0
接收感谢: 0

Re: vim卸载了装不上去了!

#5

帖子 fang0319 » 2011-04-15 9:37

:em20
O(∩_∩)O
回复

回到 “老旧版本支持”