求助(关于octave)

为当前最终发行版之前的所有版本提供支持
回复
陈为桢
帖子: 2
注册时间: 2011-03-03 9:04
送出感谢: 0
接收感谢: 0

求助(关于octave)

#1

帖子 陈为桢 » 2011-03-13 17:12

才装ubuntu没几天,我使用的是USB安装。安装过程没有任何问题,不过开机和重启的时候,经常当机......
不过,这并不是主要的,最主要的是我的Octave不能用。一下是我的Octave提示的错误信息。希望能有高手解答。
错误显示
>>> help plot
error: invalid use of script in index expression
error: called from:
error: /usr/share/octave/3.2.4/m/general/diff.m at line 109, column 5
error: /usr/share/octave/3.2.4/m/strings/strsplit.m at line 49, column
13
error: evaluating argument list element number 1
error: evaluating argument list element number 1
error: /usr/share/octave/3.2.4/m/help/__makeinfo__.m at line 110,
column 21
error: /usr/share/octave/3.2.4/m/help/help.m at line 62, column 25

正常的矩阵可以产生,但是一旦plot或者ezplot等,就会出现error。求解
答......
因为我才用ubuntu没几天,如果涉及到一些比较复杂的修改操作希望能详细解答.......谢谢
thorne
帖子: 660
注册时间: 2008-10-08 22:01
送出感谢: 0
接收感谢: 2 次

Re: 求助(关于octave)

#2

帖子 thorne » 2011-03-13 18:51

不知道 这个问题好不正常
我适用 help plot 无压力
你是apt-get安装的octave么?
天知道ubuntu下octave是什么版本

代码: 全选

其实我是个Debian GNU/Linux用户
Octave script :http://forum.ubuntu.org.cn/viewtopic.php?f=35&t=254511
Octave中文:http://forum.ubuntu.org.cn/viewtopic.php?f=35&t=318969
陈为桢
帖子: 2
注册时间: 2011-03-03 9:04
送出感谢: 0
接收感谢: 0

Re: 求助(关于octave)

#3

帖子 陈为桢 » 2011-03-14 7:44

就是用apt-get安装的,我同学的一点问题没有,我还帮他安装了的,而且直接可以打开.m的文件.......一开始我也以为是程序安装出错的问题,不过,我安了几遍都没法,他就安了一次,什么功能都可以用......而且,我的Geany没法run。同样是现实一些错误.......
回复

回到 “老旧版本支持”