求助:在ubuntu10.10安装mplayer出错

为当前最终发行版之前的所有版本提供支持
回复
烟过留声
帖子: 1
注册时间: 2011-03-18 17:32
送出感谢: 0
接收感谢: 0

求助:在ubuntu10.10安装mplayer出错

#1

帖子 烟过留声 » 2011-03-18 17:47

mplayer的相关文件如下:
MPlayer-1.0rc4.tar.bz2
essential-20071007.tar.bz2
windows-essential-20071007.zip
Blue-1.7.tar.bz2

我的步骤如下:
1.解压上面前3个文件
2.以root身份在/usr/lib下创建codes与wincodes两个文件夹
3.将essential-20071007里面的文件剪切到codes,
将windows-essential-20071007里面的文件剪切到wincodes
4.在终端取得root权限,进入MPlayer-1.0rc4目录
5.执行如下命令:
./configure --prefix=/usr/local/mplayer/ --enable-gui --enable-freetype --with-codecsdir=/usr/lib/codes/ --with-win32libdir=/usr/lib/wincodes
6.这时提示:Unknown parameter: --with-codecsdir=/usr/lib/codes/
7.于是我将命令改为:
./configure --prefix=/usr/local/mplayer/ --enable-gui --enable-freetype
8.执行命令后,提示:Error: The GUI requires libavcodec with PNG support (needs zlib).

可能是configure语句写得不对导致对,请问大家我应该怎么配置安装mplauer。
十分感谢!
hust06215
帖子: 4
注册时间: 2008-12-02 17:35
送出感谢: 0
接收感谢: 0

Re: 求助:在ubuntu10.10安装mplayer出错

#2

帖子 hust06215 » 2011-04-09 15:51

我也遇到相同的问题,求解。
头像
tenzu
论坛版主
帖子: 36913
注册时间: 2008-11-21 20:26
送出感谢: 0
接收感谢: 21 次

Re: 求助:在ubuntu10.10安装mplayer出错

#3

帖子 tenzu » 2011-04-09 16:09

缺东西,写的很清楚了
apt-get install一下不好么?
头像
qy117121
论坛版主
帖子: 49890
注册时间: 2007-12-14 13:40
系统: Winbuntu
来自: 志虚国乌由市
送出感谢: 17 次
接收感谢: 334 次
联系:

Re: 求助:在ubuntu10.10安装mplayer出错

#4

帖子 qy117121 » 2011-04-09 16:28

tenzu 写了:缺东西,写的很清楚了
apt-get install一下不好么?
渠月 · QY    https://vz.rs/u
本人只会灌水,不负责回答问题

无聊可以点一下→ http://u.nu/ubuntu
头像
自由建客
论坛版主
帖子: 13436
注册时间: 2008-07-30 23:21
系统: Debian stable AMD64
来自: freebuilder@yeah.net
送出感谢: 12 次
接收感谢: 112 次
联系:

Re: 求助:在ubuntu10.10安装mplayer出错

#5

帖子 自由建客 » 2011-04-09 18:36

自带的 mplayer 不好用?
回复

回到 “老旧版本支持”