[问题]哪一个命令是产生vmlinuz-2.6.*文件的

为当前最终发行版之前的所有版本提供支持
回复
lisir
帖子: 1187
注册时间: 2006-04-29 14:54
来自: 山东
送出感谢: 0
接收感谢: 0
联系:

[问题]哪一个命令是产生vmlinuz-2.6.*文件的

#1

帖子 lisir » 2006-11-22 1:18

因为在我的c61v主板上无法正常安装6.06(据说新内核可以支持),所以我试图先在安装时加入参数:noapic nolapic先安装上,再升级内核(内核是下载到同机的xp上了)前面的步骤都没有问题了,(在安装时就提示无法找到网卡。因无法正常进入,即使在启动命令上加上那两个参数也不行,说是无法启动X Server,但可以进入字符界面)但在升级内核时遇到了几个问题:

1、执行make gconfig说是没有安装gtk的开发包。不知该如何在命令行添加这些开发包,关键是开发包的名称。我试图用sudo apt-get install gtk*的方式安装,但无效。
用make menuconfig也不行,虽然显示得好象执行了,但在执行下一条make mclean时提示没有进行config,

我采用make defconfig和make config两种方式分别替代make menuconfig。这一步通过。
2、后面的make install \ make modules\make modules_install也都正常执行了。在执行/usr/sbin/mkinitramfs -o /boot/initrd.img-2.6.18.3 2.6.18.3时出错,提示在/lib/modules找不到2.6.18.3,我经过一番查找,将命令缩减为/usr/sbin/mkinitramfs -o /boot/initrd.img-2.6.18.3,这样倒是可以在/boot下生成initrd.img-2.6.18.3了,但在想修改menu.lst时犯了愁,initrd后面的参数虽然有了,但kernel后的参数没有,也就是它需要的vmlinux-2.6.18.3没有,在/boot下查看一下,有原来版本的,但新版本内核的vmlinuz没有生成,但网上文章中提到的命令我都执行了,怎么还没有?

请大侠指教!
回复

回到 “老旧版本支持”