新手源码安装gaim时configure时出错

为当前最终发行版之前的所有版本提供支持
回复
uncoldice
帖子: 8
注册时间: 2006-07-04 19:42
送出感谢: 0
接收感谢: 0

新手源码安装gaim时configure时出错

#1

帖子 uncoldice » 2006-11-22 15:57

源码方式安装gaim1.5,在configure时候出现这样的错误:

代码: 全选

checking for GLIB - version >= 2.0.0...
*** 'pkg-config --modversion glib-2.0' returned 2.12.0, but GLIB (2.10.3)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error:
*** GLib 2.0 is required to build Gaim; please make sure you have the GLib
*** development headers installed. The latest version of GLib is
*** always available at http://www.gtk.org/.
我估计是因为我以前用apt-get升级过glib-2.0导致版本混乱所致.到网上搜索一下,好像只要修改/etc/ld.so.conf文件添加一个/usr/local/lib的路径就可以了。但是很遗憾在ubuntu里面没有这个文件呢。
本来好像可以用apt-get install gaim来解决,但是我那个环境现在上网不方便。而且,我确实想搞明白这个错误的解决方法,因为我另一个同学在redhat下面也遇到过这样的问题。
哪位高手可以指点一下呢?
uncoldice
帖子: 8
注册时间: 2006-07-04 19:42
送出感谢: 0
接收感谢: 0

#2

帖子 uncoldice » 2006-11-22 21:56

又或者是,ubuntu 下面的 ld.so.conf 文件不叫这个名字?
头像
lyreopera
帖子: 771
注册时间: 2005-05-23 13:38
来自: gdsz
送出感谢: 0
接收感谢: 0

#3

帖子 lyreopera » 2006-11-22 22:24

我觉得你该把glib2-devel(不知道是不是这个名字)装上去……
……
uncoldice
帖子: 8
注册时间: 2006-07-04 19:42
送出感谢: 0
接收感谢: 0

#4

帖子 uncoldice » 2006-11-23 10:56

lyreopera 写了:我觉得你该把glib2-devel(不知道是不是这个名字)装上去……
这个我已经装了的……
回复

回到 “老旧版本支持”