当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 安装显卡驱动后分辨率问题
帖子发表于 : 2011-03-21 16:51 

注册: 2008-06-22 10:12
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
ubuntu 10.04
先把原来的显卡驱动都删除了apt-get remove nvidia*
然后在官网下了nvidia的显卡驱动,然后安装。
结束后发现root登录的分辨率是1440x900,可是普通用户登录的分辨率是800x600,而且登录分辨率和进入桌面的分辨率不一致
其中xorg.conf文件如下:
nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 260.19.29 (buildmeister@swio-display-x86-rhel47-08.nvidia.com) Wed Dec 8 12:28:43 PST 2010

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 260.19.29 (buildmeister@swio-display-x86-rhel47-08.nvidia.com) Wed Dec 8 12:28:55 PST 2010

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "0"
EndSection

Section "Module"
Load "glx"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "BenQ FP92W"
HorizSync 30.0 - 83.0
VertRefresh 56.0 - 76.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 210"
EndSection

Section "Screen"

# Removed Option "metamodes" "nvidia-auto-select +0+0"
# Removed Option "metamodes" "1440x900 +0+0; nvidia-auto-select +0+0"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "NoLogo" "True"
Option "TwinView" "0"
Option "metamodes" "1440x900_60 +0+0; 1440x900 +0+0; nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection


而且我在level 3下startx之后,看到的记录文件/var/log/Xorg.0.log有那么几行:
(II) No input driver/identifier specified (ignoring)
(II) Mar 21 16:24:50 NVIDIA(0): Setting mode "800x600"
[mi] EQ overflowing. The server is probably stuck in an infinite loop.

如果我用root登录的话是没有第二第三行的记录,我不明白为什么startx会设定mode为800x600,因为xorg.conf中都已有设定。
求牛人解答。。。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 安装显卡驱动后分辨率问题
帖子发表于 : 2011-03-21 16:59 
头像

注册: 2007-02-02 18:14
帖子: 30702
系统: debian sid
送出感谢: 1
接收感谢: 34
这个很麻烦的...nvidia不支持kms...也不一定有你要的分辨率


_________________
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Bing [Bot], Yahoo [Bot] 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译