关于JAV的小问题

为当前最终发行版之前的所有版本提供支持
回复
shuyu0
帖子: 45
注册时间: 2011-03-02 10:28
送出感谢: 0
接收感谢: 0

关于JAV的小问题

#1

帖子 shuyu0 » 2011-03-21 18:29

我测试了Hello.java.
然后说:
程序“javac”已包含在下列软件包中:
* openjdk-6-jdk
* ecj
* gcj-4.4-jdk
* gcj-4.5-jdk
请尝试:sudo apt-get install <选定的软件包>

我以为要更新 然后 执行了
sudo apt-get install openjdk-6-jdk
但是

正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
E: 未发现软件包 open-6-jdk

然后我再java -version

java version "1.6.0_20"
OpenJDK Runtime Environment (IcedTea6 1.9.7) (6b20-1.9.7-0ubuntu1)
OpenJDK Client VM (build 19.0-b09, mixed mode, sharing)

这到底是怎么回事啊,谁能帮帮我

THX
头像
退避九舍
帖子: 741
注册时间: 2010-08-08 20:02
系统: Ubuntu 12.04
送出感谢: 0
接收感谢: 1 次

Re: 关于JAV的小问题

#2

帖子 退避九舍 » 2011-03-21 18:33

你只装了jre吧,而没有安装jdk吧。
退避九舍:富贵不能淫,贫贱不能移,威武不能屈:坚持ubuntu不动摇!
shuyu0
帖子: 45
注册时间: 2011-03-02 10:28
送出感谢: 0
接收感谢: 0

Re: 关于JAV的小问题

#3

帖子 shuyu0 » 2011-03-21 18:52

退避九舍 写了:你只装了jre吧,而没有安装jdk吧。
那现在我该--
shuyu0
帖子: 45
注册时间: 2011-03-02 10:28
送出感谢: 0
接收感谢: 0

Re: 关于JAV的小问题

#4

帖子 shuyu0 » 2011-03-21 19:08

谢谢你了,我安装了JDK。
但是为什么不需要设置环境变量呢?
就可以直接运行了呐?
回复

回到 “老旧版本支持”