安装vim的过程中出现问题[求助]

为当前最终发行版之前的所有版本提供支持
回复
xuheer
帖子: 18
注册时间: 2010-01-02 14:47
送出感谢: 0
接收感谢: 0

安装vim的过程中出现问题[求助]

#1

帖子 xuheer » 2011-03-23 11:52

我用的是Ubuntu9.10,打算安装完整的vim编辑器,所以我用apt-get install vim安装vim。但是我在安装的过程中出现了错误,不知道怎么解决,请各位帮我分析一下。

root@ubuntu:/mnt/hgfs/CCPP# apt-get install vim
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package vim is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package vim has no installation candidate

根据错误提示,vim包没有安装的资格,这是怎么回事呢?

谢谢了。
头像
nmsfan
帖子: 18958
注册时间: 2009-10-16 22:46
来自: finland
送出感谢: 16 次
接收感谢: 36 次

Re: 安装vim的过程中出现问题[求助]

#2

帖子 nmsfan » 2011-03-23 11:55

试试vim-full(好象是这么写的)
>>>>推Ubuntu 桌面培训~~<<<<
>>>>想加入/了解gimp汉化吗,点我吧~<<<<
——————————————————————
不推荐wubi,也不推荐你给别人推荐wubi…………
随心而为的感觉真好……
强推mayhem!!
强推ensiferum
xuheer
帖子: 18
注册时间: 2010-01-02 14:47
送出感谢: 0
接收感谢: 0

Re: 安装vim的过程中出现问题[求助]

#3

帖子 xuheer » 2011-03-23 16:16

我试了下你的想法,会有下面的提示:
---------------------------------------
root@ubuntu:/mnt/hgfs/CCPP# apt-get install vim-full
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package vim-full
------------------------------------------

提示说找不到这个包,不知道为什么找不到。
nmsfan 写了:试试vim-full(好象是这么写的)
booduklee
帖子: 4
注册时间: 2011-04-06 21:32
送出感谢: 0
接收感谢: 0

Re: 安装vim的过程中出现问题[求助]

#4

帖子 booduklee » 2011-04-06 23:24

你可以用这个apt-get install vim-gtk来解决
头像
zhuangxiaomeng
帖子: 454
注册时间: 2010-03-15 14:14
送出感谢: 0
接收感谢: 0
联系:

Re: 安装vim的过程中出现问题[求助]

#5

帖子 zhuangxiaomeng » 2011-04-07 11:38

加源 :em04
windows7 +Linuxdeepin 11.12 +debian testing
头像
ffdqlff
帖子: 78
注册时间: 2011-01-27 16:36
送出感谢: 0
接收感谢: 0

Re: 安装vim的过程中出现问题[求助]

#6

帖子 ffdqlff » 2011-04-12 22:36

UESTC源欢迎你的加入
不是尤里·纳吉宾式的结局,而应该是欧·亨利式的结局!
回复

回到 “老旧版本支持”