在终端输入命令时出现的错误?

为当前最终发行版之前的所有版本提供支持
回复
诗韵眼泪
帖子: 19
注册时间: 2011-03-22 20:01
送出感谢: 0
接收感谢: 0

在终端输入命令时出现的错误?

#1

帖子 诗韵眼泪 » 2011-03-23 18:02

第一个问题:ubuntu10.10在终端输入:sudo dpkg -i ppstream_1.0.1-1_i386.deb时会出现:dpkg:另外一个进程已经为状态数据库加了锁的提示。这是为什么?应该怎么样解决?
第二个问题:ubuntu10.10在终端输入:sudo apt-get install poppler-data是会出现:E:无法获得锁/var/lip/dpkg/lock - open(11:资源暂时不可用)
E:无法锁定管理目录(/var/lib/dpkg/),是否有其他进程正占用它?
chole
帖子: 482
注册时间: 2010-05-11 17:27
送出感谢: 9 次
接收感谢: 0

Re: 在终端输入命令时出现的错误?

#2

帖子 chole » 2011-03-23 18:14

因为ubuntu一次只能运行一个 apt-get
头像
tenzu
论坛版主
帖子: 36913
注册时间: 2008-11-21 20:26
送出感谢: 0
接收感谢: 21 次

Re: 在终端输入命令时出现的错误?

#3

帖子 tenzu » 2011-03-23 18:58

代码: 全选

sudo rm /var/lib/dpkg/lock
确认同一时间没有其他apt-get运行
回复

回到 “老旧版本支持”