为什么挂载不上U盘?

为当前最终发行版之前的所有版本提供支持
回复
ilsoviet1917
帖子: 270
注册时间: 2009-11-11 23:13
送出感谢: 3 次
接收感谢: 0

为什么挂载不上U盘?

#1

帖子 ilsoviet1917 » 2011-03-24 17:12

把U盘插入后会跳出一个错误

Error mounting: mount exited with exit code 1: helper failed with:
mount: wrong fs type, bad option, bad superblock on /dev/sdb1,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

我装了ntfs-3g后也不行,我的系统是debian。

:em20
同志们,多年的战争使你们踏遍整个欧洲,前方就是华盛顿白宫,到那里去洗刷你们战争的躯体吧!
fuxiu
帖子: 208
注册时间: 2009-12-01 20:02
送出感谢: 0
接收感谢: 0

Re: 为什么挂载不上U盘?

#2

帖子 fuxiu » 2011-03-24 17:37

是用u盘安装的系统吗?
ilsoviet1917
帖子: 270
注册时间: 2009-11-11 23:13
送出感谢: 3 次
接收感谢: 0

Re: 为什么挂载不上U盘?

#3

帖子 ilsoviet1917 » 2011-03-24 19:35

fuxiu 写了:是用u盘安装的系统吗?
一开始我用这个优盘做了一个大便启动盘,装完了以后就格式化,然后就挂载不上了。奇怪的是仅仅在大便里挂不上,在windows下和ubuntu下都能挂载上。
同志们,多年的战争使你们踏遍整个欧洲,前方就是华盛顿白宫,到那里去洗刷你们战争的躯体吧!
fuxiu
帖子: 208
注册时间: 2009-12-01 20:02
送出感谢: 0
接收感谢: 0

Re: 为什么挂载不上U盘?

#4

帖子 fuxiu » 2011-03-24 21:06

我也是用u盘装的,没解决。于是改用cd装,就能挂载了。
笙昊歆
帖子: 3
注册时间: 2011-03-25 8:02
送出感谢: 0
接收感谢: 0

Re: 为什么挂载不上U盘?

#5

帖子 笙昊歆 » 2011-03-25 8:12

如果用的是虚拟机的话,还要看看你的虚拟机有没有识别USB!
ilsoviet1917
帖子: 270
注册时间: 2009-11-11 23:13
送出感谢: 3 次
接收感谢: 0

Re: 为什么挂载不上U盘?

#6

帖子 ilsoviet1917 » 2011-03-25 8:40

绝对不是虚拟机!
同志们,多年的战争使你们踏遍整个欧洲,前方就是华盛顿白宫,到那里去洗刷你们战争的躯体吧!
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

Re: 为什么挂载不上U盘?

#7

帖子 eexpress » 2011-03-25 10:41

/dev/sdb1 是ntfs???
谁叫你这样安装的?wubi?
● 鸣学
ilsoviet1917
帖子: 270
注册时间: 2009-11-11 23:13
送出感谢: 3 次
接收感谢: 0

Re: 为什么挂载不上U盘?

#8

帖子 ilsoviet1917 » 2011-03-25 13:11

eexpress 写了:/dev/sdb1 是ntfs???
谁叫你这样安装的?wubi?
不是WUBI,是一般的双系统模式,一部分硬盘装XP,一部分装大便,然后GRUB选择启动。
再说我也么有什么sdb1啊,就一块硬盘。
难道是因为我这个U盘是8G的?


下面是fdisk -l后的结果

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xf601f601

Device Boot Start End Blocks Id System
/dev/sda1 * 1 2550 20482843+ 7 HPFS/NTFS
/dev/sda2 2551 38914 292087974+ f W95 Ext'd (LBA)
/dev/sda5 2551 3570 8193118+ 7 HPFS/NTFS
/dev/sda6 3571 13416 79087963+ 7 HPFS/NTFS
/dev/sda7 13417 15848 19530752 83 Linux
/dev/sda8 15848 16055 1658880 82 Linux swap / Solaris
/dev/sda9 16055 18243 17576960 83 Linux
/dev/sda10 18243 38914 166036480 83 Linux

Disk /dev/sdb: 8002 MB, 8002732032 bytes
37 heads, 37 sectors/track, 11417 cylinders
Units = cylinders of 1369 * 512 = 700928 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000552ac

Device Boot Start End Blocks Id System
/dev/sdb1 * 6 11418 7811136 b W95 FAT32
同志们,多年的战争使你们踏遍整个欧洲,前方就是华盛顿白宫,到那里去洗刷你们战争的躯体吧!
头像
hecha
帖子: 364
注册时间: 2007-09-23 13:36
送出感谢: 0
接收感谢: 2 次

Re: 为什么挂载不上U盘?

#9

帖子 hecha » 2011-03-25 19:11

昨晚我刚用 U 盘重装了系统
装完发现 U 盘挂载不了,插上,在 “计算机” 里可以看到,一会就消失了
后来发现,fstab 中

代码: 全选

/dev/sdb1       /               ext4    errors=remount-ro 0       1
# /var was on /dev/sdb2 during installation
UUID=5499b7a0-5485-44d1-b700-af9bb0179568 /var            ext4    defaults        0       2
# /home was on /dev/sdb3 during installation
UUID=e7f140be-80bf-4075-a4fc-267c0da9e5d7 /home           ext4    defaults        0       2
因为装系统时,硬盘是 /dev/sdb,系统装好后,U 盘是 /dev/sdb
将 fstab 中 sdb 改成 sda,U 盘就可以挂载了
口口!口口被口口了!
ilsoviet1917
帖子: 270
注册时间: 2009-11-11 23:13
送出感谢: 3 次
接收感谢: 0

Re: 为什么挂载不上U盘?

#10

帖子 ilsoviet1917 » 2011-03-25 19:15

我用了一个比较笨的办法

先在/media下建立一个文件夹usb,U盘是/dev/sdb,然后把sdb挂载到/media/usb下。

代码: 全选

mkdir /media/usb
mount /dev/sdb /media/usb
这个方法能挂载U盘,而且在图形界面和字符界面下都可以操作,卸载的时候还是字符界面下卸载。
不过怎么能像以前一样呢?
同志们,多年的战争使你们踏遍整个欧洲,前方就是华盛顿白宫,到那里去洗刷你们战争的躯体吧!
jusbim
帖子: 2
注册时间: 2009-07-05 9:47
送出感谢: 0
接收感谢: 0

Re: 为什么挂载不上U盘?

#11

帖子 jusbim » 2011-11-18 12:58

刚刚装debian 6 CD-1 U盘安装也遇到这问题,解决方法:vim /etc/fstab sdb 那行删除
回复

回到 “老旧版本支持”