NX远程控制问题请教

为当前最终发行版之前的所有版本提供支持
回复
carl9081
帖子: 106
注册时间: 2008-10-31 15:22
送出感谢: 3 次
接收感谢: 0

NX远程控制问题请教

#1

帖子 carl9081 » 2011-03-30 20:24

在http://forum.ubuntu.org.cn/viewtopic.php?f=169&t=288344帖子中,知道了NX客户端里通过设置Configure--->General--->Desktop里选择 Shadow ,就可以实时的看到远程的桌面了,而不是看到新建的一个桌面
图片
可我按照这个设置连接时,碰到如下情况而无法连接:
图片
图片
请问,我该如何解决?这种连接方法连接后,是不是和同一用户在本地登陆所取得的权限一模一样?
头像
Crazier
帖子: 1051
注册时间: 2007-09-23 17:06
送出感谢: 1 次
接收感谢: 8 次
联系:

Re: NX远程控制问题请教

#2

帖子 Crazier » 2011-03-30 21:00

是不是你的服务器端的设置成不允许啊?执行下面命令
cat /usr/NX/etc/server.cfg |grep -i shadow
看看是否跟下面的一样,贴出来看看
# Allow session shadowing on this server:
# 0: Disabled. Session shadowing is forbidden.
#EnableSessionShadowing = "1"
# Allow session shadowing in interactive mode:
# 0: Disabled. The session is shadowed in view-only mode. User
#EnableInteractiveSessionShadowing = "1"
#EnableSessionShadowingAuthorization = "1"
# 0: Disabled. The session is shadowed in view-only mode. User
另外,把你的那个截图的Detail内容打开看看。。。
carl9081
帖子: 106
注册时间: 2008-10-31 15:22
送出感谢: 3 次
接收感谢: 0

Re: NX远程控制问题请教

#3

帖子 carl9081 » 2011-03-30 21:38

cat /usr/NX/etc/server.cfg |grep -i shadow
输出结果为:

# Allow session shadowing on this server:
# 0: Disabled. Session shadowing is forbidden.
#EnableSessionShadowing = "1"
# Allow session shadowing in interactive mode:
# 0: Disabled. The session is shadowed in view-only mode. User
#EnableInteractiveSessionShadowing = "1"
#EnableSessionShadowingAuthorization = "1"
# 0: Disabled. The session is shadowed in view-only mode. User
头像
Crazier
帖子: 1051
注册时间: 2007-09-23 17:06
送出感谢: 1 次
接收感谢: 8 次
联系:

Re: NX远程控制问题请教

#4

帖子 Crazier » 2011-03-31 9:20

嗯,这就不知道了,我的就可以正常使用。你看一下LOg是怎么说的,或者把你原来的帐号删除掉,再新建一个,看是否有用。。。
carl9081
帖子: 106
注册时间: 2008-10-31 15:22
送出感谢: 3 次
接收感谢: 0

Re: NX远程控制问题请教

#5

帖子 carl9081 » 2011-03-31 9:21

Detail内容为:



NX> 203 NXSSH running with pid: 3788
NX> 285 Enabling check on switch command
NX> 285 Enabling skip of SSH config files
NX> 285 Setting the preferred NX options
NX> 200 Connected to address: 192.168.1.16 on port: 22
NX> 202 Authenticating user: nx
NX> 208 Using auth method: publickey
HELLO NXSERVER - Version 3.4.0-14 - LFE
NX> 105 Hello NXCLIENT - Version 3.4.0
NX> 134 Accepted protocol: 3.4.0
NX> 105 Set shell_mode: shell
NX> 105 Set auth_mode: password
NX> 105 Login
NX> 101 User: (省略)
NX> 102 Password: ********
NX> 103 Welcome to: (省略) user: (省略)
NX> 105 Listsession --type="shadow"
NX> 127 Session list possible to attach::

Display Type Session ID Services depth Screensize Status Session Name Username
------- ------------ -------------------------------- -------- ---- -------------- ----------- --------------------- ----------------
0 X11-local 166A8EFE1324A2A233E47EAEDB9D3FE2 --D--PSA N/A N/A Running Local display gdm
NX> 105 Listsession --type="shadow"
NX> 127 Session list possible to attach::

Display Type Session ID Services depth Screensize Status Session Name Username
------- ------------ -------------------------------- -------- ---- -------------- ----------- --------------------- ----------------
0 X11-local 166A8EFE1324A2A233E47EAEDB9D3FE2 --D--PSA N/A N/A Running Local display gdm
NX> 105 Attachsession --link="lan" --backingstore="1" --encryption="1" --cache="16M" --images="64M" --shmem="1" --shpix="1" --strict="0" --composite="1" --media="0" --session="62" --type="shadow" --client="winnt" --keyboard="pc105\057us" --id="166A8EFE1324A2A233E47EAEDB9D3FE2" --display="0" --geometry="N\057A" --resize="1"
NX> 596 ERROR: Cannot share session of user: gdm.
NX> 596 ERROR: User: gdm is not a NX user.
NX> 105 NX> 280 Exiting on signal: 15
carl9081
帖子: 106
注册时间: 2008-10-31 15:22
送出感谢: 3 次
接收感谢: 0

Re: NX远程控制问题请教

#6

帖子 carl9081 » 2011-03-31 11:11

Crazier 写了:嗯,这就不知道了,我的就可以正常使用。你看一下LOg是怎么说的,或者把你原来的帐号删除掉,再新建一个,看是否有用。。。
请问你是如何装NX的?装后哪里配置过?
carl9081
帖子: 106
注册时间: 2008-10-31 15:22
送出感谢: 3 次
接收感谢: 0

Re: NX远程控制问题请教

#7

帖子 carl9081 » 2011-04-05 10:03

这么多天了,还没人回复,看来是没戏了
回复

回到 “老旧版本支持”