help!

为当前最终发行版之前的所有版本提供支持
回复
ronaldoa
帖子: 36
注册时间: 2006-11-24 14:45
送出感谢: 0
接收感谢: 0

help!

#1

帖子 ronaldoa » 2006-11-25 19:11

sudo apt-get install g++

正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
g++: 依赖: g++-4.0 (>= 4.0.3) 但是它将不会被安装
E: 无法安装的软件包

sudo apt-get install gcc g++ libgcc1 libg++ make gdb

正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
gcc 已经是最新的版本了。
libgcc1 已经是最新的版本了。
注意,我选了 libg++2.8.1.3-glibc2.2 而非 libg++
make 已经是最新的版本了。
gdb 已经是最新的版本了。
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
g++: 依赖: g++-4.0 (>= 4.0.3) 但是它将不会被安装
E: 无法安装的软件包

sudo apt-get install scim-chinese
还是不行,老样子啊



用官方源,还是不行,老样子啊,update行,but others can't,there's why?
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#2

帖子 BigSnake.NET » 2006-11-25 19:36

sudo vim /etc/apt/sources.list
设置好源

sudo apt-get update ; sudo apt-get upgrade ;sudo apt-get install build-essential
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
回复

回到 “老旧版本支持”